【C++】AOJ基础题 ITP1_8_D Ring

Ring

Write a program which finds a pattern p in a ring shaped text s.
在这里插入图片描述

Input

In the first line, the text s is given. In the second line, the pattern p is given.

Output

If p is in s, print Yes in a line, otherwise No.

Constraints

  • 1 ≤ length of p ≤ length of s ≤100
  • s and p consists of lower-case letters

Sample Input

vanceknowledgetoad
advance

Sample Output

Yes

問題を解く

#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string.h>
using namespace std;

int main()
{
	char a[1000];
	char b[1000];
	char c[1000];

	cin.getline(a, 1000);
	cin.getline(b, 1000);

	strcpy(c, a);

	strcat(a, c);

	if (strstr(a, b))
	{
		cout << "Yes" << endl;
	}
	else
	{
		cout << "No" << endl;
	}


	return 0;
}

改进

#include<iostream>
#include<string>

using namespace std;

int main()
{
  string s,p;
  
  cin >> s >> p;
  
  // 这里当初没有想到
  s=s+s;
  
  if(s.find(p)!=-1) cout << "Yes" << endl;
  else cout << "No" << endl;
  
  return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值