【C++】AOJ基础题 ITP1_10_C Standard Deviation

Standard Deviation

You have final scores of an examination for n students. Calculate standard deviation of the scores s1, s2 … sn.

The variance α^2 is defined by

α^2 = (∑ni=1(si - m)2)/n

where m is an average of si. The standard deviation of the scores is the square root of their variance.

Input

The input consists of multiple datasets. Each dataset is given in the following format:

n
s1 s2 ... sn

The input ends with single zero for n.

Output

For each dataset, print the standard deviation in a line. The output should not contain an absolute error greater than 10^-4.

Constraints

  • n ≤ 1000
  • 0 ≤ si ≤ 100

Sample Input

5
70 80 100 90 20
3
80 80 80
0

Sample Output

27.85677655
0.00000000

問題を解く

  • 最简单解法,直接按公式算。
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <iomanip>

double average(double* s, int n)
{
	double sum = 0;
	for (int i = 0; i < n; i++)
	{
		sum += s[i];
	}

	double avg = sum / n;

	return avg;
}

using namespace std;

int main() {
	int n = 0;
	double s[1001] = { 0 };
	double t[1001] = { 0 };

	while (true)
	{
		cin >> n;
		if (n == 0) break;

		for (int i = 0; i < n; i++)
		{
			cin >> s[i];
		}

		for (int i = 0; i < n; i++)
		{
			t[i] = pow((s[i] - average(s, n)), 2);
		}

		double sd = sqrt(average(t,n));

		cout << fixed << setprecision(10);
		cout << sd << endl;
	}

}

A Good Try

  • 用vector来写也许会简单很多!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值