几道C语言练习题

Write a function expand(s1,s2) that expands shorthand notations like a-z in the string s1 into the equivalent complete list abc...xyz in s2. Allow for letters of either case and digits, and be prepared to handle cases like a-b-c and a-z0-9 and -a-z and a--z. Arrange that a leading or trailing - is taken literally.

SAMPLE INPUT:

a-z
A-A
0-9
c--z
-a-c
a-cf
a-c-f

SAMPLE OUTPUT:

abcdefghijklmnopqrstuvwxyz
A
0123456789
c--z
-abc
abcf
abcdef
#include <stdio.h>
#include <assert.h>
#include <ctype.h>

const int N = 10001;

void expand(char [], char []);

int main()
{
//    freopen("0.in", "r", stdin);
//    freopen("0.out", "w", stdout);

    char s1[N], s2[N * 30];

    while(scanf("%s", s1) != EOF) {
        expand(s1, s2);
        printf("%s\n", s2);
    }

    return 0;
}

void expand(char s1[],char s2[]){
    int i,j;
    i=j=0;
    int length;

    while(s1[i]!='\0'){
        switch (s1[i]) {
            case '-':
                if(i==0||s1[i+1]-s1[i-1]<0){
                    i++;
                    s2[j++]='-';
                    break;
                }
                if(islower(s1[i-1]) && islower(s1[i+1]) || isupper(s1[i-1])  && isupper(s1[i+1]) || isdigit(s1[i-1]) && isdigit(s1[i+1])){
                    length =s1[i+1]-s1[i-1];
                    for(int z=0;z<=length;z++){
                        s2[j-1+z]=s1[i-1]+z;
                    }
                    i=i+2;
                    j=j+length;
                }
                else{
                    i++;
                    s2[j++]='-';
                }
                break;
            default:
                s2[j++]=s1[i++];
                break;
        }
    }
    s2[j]='\0';
}





编写程序计算某年某月某日是该年中的第几天。

输入格式:

输入在一行中按照格式“yyyy/mm/dd”(即“年/月/日”)给出日期。注意:闰年的判别条件是该年年份能被4整除但不能被100整除、或者能被400整除。闰年的2月有29天。

输出格式:

在一行输出日期是该年中的第几天。

#include<stdio.h>

int days[] ={31,28,31,30,31,30,31,31,30,31,30,31};
int daysR[] ={31,29,31,30,31,30,31,31,30,31,30,31};

int CheckYear(int input){
	if((!(input%4)&&input%100)||(!(input%400)))return 1;
	else return 0;
}

int main(){
	int p[3];
	int a,b,c;
	scanf("%d/%d/%d",&a,&b,&c);
	int output=0;
	if(CheckYear(a)){
		for(int i=0;i<b-1;i++){
			output+=daysR[i];
		}
		output+=c;
	} else {
		for(int i=0;i<b-1;i++){
			output+=days[i];
		}
		output+=c;
	}
	printf("%d\n",output);
}

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

结尾无空行

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
#include<stdio.h>


void Change(int target[54][2], int length, int as[]);

int main() {
	//初始化牌的序列
	char a[5] = { 'S','H','C','D','J' };
	int b[13] = { 1,2,3,4,5,6,7,8,9,10,11,12,13 };
	int c[54][2];
	int tempA = 0;
	for (int i = 0; i < 54; i++) {
		c[i][0] = a[tempA+(i/13)];
		c[i][1] = b[i%13];
	}
	int repeat;
	scanf("%d", &repeat);
	int p[54];
	int temp;
	for (int i = 0; i < 54; i++) {
		scanf("%d", &temp);
		p[i] = temp;
	}


	for (int i = 0; i < repeat; i++) {
		Change(c, 54,p);
	}

	for (int i = 0; i < 53; i++) {
		printf("%c%d ", c[i][0], c[i][1]);
	}
	printf("%c%d", c[53][0], c[53][1]);
}



void Change(int target[54][2], int length, int as[]) {
	int output[54][2];
	int temp;

	for (int i = 0; i < 54;i++) {
		output[as[i]-1][0] = target[i][0];
		output[as[i]-1][1] = target[i][1];
	}

	for (int i = 0; i < 54; i++) {
		target[i][0] = output[i][0];
		target[i][1] = output[i][1];
	}
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值