poj1742Coins 多重背包可行性

Coins

总时间限制: 

3000ms

 

内存限制: 

65536kB

描述

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

输入

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

输出

For each test case output the answer on a single line.

样例输入

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

样例输出

8
4

思路:

一道多重背包的可行性问题,开两个数组vis[ i ]和dp[ i ]分别记录是否已经得到面额 i 和当前循环种类的面额的硬币的使用次数

详细的解释全在代码里了

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int maxn = (int)1e5 + 10;
int dp[maxn];
int v[110],s[110];
bool vis[maxn];
int main()
{
	int n,m;
	while (~scanf("%d %d",&n,&m) && (n + m))
    {
        for (int i = 1;i <= n;i ++)
            scanf("%d",&v[i]);
        for (int i = 1;i <= n;i ++)
            scanf("%d",&s[i]);
        mem(vis);
        int ans = 0;
        vis[0] = 1;     //面额为0肯定是不用硬币就能凑出的
        for (int i = 1;i <= n;i ++)
        {
            mem(dp);      //由于当前的硬币种类之前并没有使用过,要初始化为0
            for (int j = v[i];j <= m;j ++)
            {
                if (!vis[j] && vis[j - v[i]] && dp[j - v[i]] + 1 <= s[i])
                {                            //对于当前种类的硬币面额j
                    vis[j] = 1;              //如果j - v[i] 已经存在且j还没有被
                    ans ++;                  //凑出,并且当前第i种硬币的使用次数
                    dp[j] = dp[j - v[i]] + 1;//小于本就有的,说明面额j可以被凑出
                }                            //,这样会把已经凑出的j剪枝,省时
            }
        }
        printf("%d\n",ans);
    }
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值