POJ_1787_多重背包方案记录

Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task. 

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".

Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define  MAX_M 10005
#define MAX_N 10
//dp[i][j]的定义就是使用前i中硬币时,支付j元第i种硬币最多可以剩余多少个
int dp[MAX_M];
int path[MAX_M];//path[j]元的定义是生成j元的前一步是多少元,j-path【j】就可以算出加上的这个硬币面额的差值
int used[MAX_M];//代表使用该种硬币的个数
int ans[MAX_M];
int v[5] ={1,5,10,25};
int m[MAX_N];//代表起初各种硬币的数目
int s[MAX_N];//代表完成支付后各种硬币的数目
int M;//代表总钱数
int main()
{
    freopen("背包H-多重背包方案记录.txt", "r",stdin);
    while(~scanf("%d",&M))
    {
        memset(dp,0,sizeof(dp));

        memset(ans,0,sizeof(ans));

        memset(path,0,sizeof(path));

        for(int i=0;i<4;i++)
        {
            scanf("%d",m+i);

        }

        if(M==m[0]&&m[0]==m[1]&&m[1]==m[2]&&m[2]==m[3]&&m[3]==0)
        {
            break;
        }
        void solve();
        solve();
    }
    return 0;

}
void solve()
{

    dp[0]=1;
    //因为尽可能的支付的硬币数要多,所以又贪心的思想我们可知,要尽可能选取面额小的硬币种类

    for(int i=0;i<4;i++)
    {
        memset(used,0,sizeof(used));
        for(int j=v[i];j<=M;j++)
        {
            if(dp[j-v[i]]&&dp[j-v[i]]+1>dp[j]&&used[j-v[i]]<m[i])
            {
                dp[j]=dp[j-v[i]]+1;
                used[j]=used[j-v[i]]+1;
                path[j]=j-v[i];//j元的前一步是j-v[i],记录路径
                //cout<<"path "<<path[j]<<" i   "<<i<<"  j "<<j<<" j-v[i] "<<j-v[i]<<endl;
            }
        }
    }

    int i=M;
    if(dp[M]>0)
    {
        while(i!=0)
        {
            ans[i-path[i]]++;
            i=path[i];
        }
        printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",ans[1],ans[5],ans[10],ans[25]);
    }
    else{
        printf("Charlie cannot buy coffee.\n");
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值