poj 2311 cutting game

Cutting Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3553 Accepted: 1323

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print "WIN", otherwise, print "LOSE".

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE
WIN

Source

POJ Monthly,CHEN Shixi(xreborner)

题解:sg函数的博弈问题。刚开始看这道题的时候,有些无从下手。后经过小动物(orz zyx神犇)的指点,才明白如何建立SG函数。
这道题就是一个N*M的方格,两个人轮流去切,可以横着切,也可以竖着切,第一个切出一个方格的人胜利,问先手是否有必胜策略。首先很容易想到的就是如果只有一行或只有一列那么先手只需要切下一个方格就必胜了。那么我们可以这么想每次都是一刀把方格切成两部分,那么两个部分共同影响当前的状态,也就是当前状态等于两个部分异或的答案,因为只有当两部分都是必胜的才能保证当前必胜,所以可以通过不断细分去求解。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,sg[210][210];
void get_sg()
{
  bool hash[50003];
  for (int i=2;i<=200;i++)
   for (int j=2;j<=200;j++)
    {
      memset(hash,0,sizeof(hash));
      for (int k=2;k+k<=i;k++)
       hash[sg[k][j]^sg[i-k][j]]=1;
      for (int k=2;k+k<=j;k++)
       hash[sg[i][k]^sg[i][j-k]]=1;
      for (int k=0;;k++)
       if (!hash[k])
        {
          sg[i][j]=k;
          break;
        }
    }
}
int main()
{
  memset(sg,0,sizeof(sg));
  get_sg();
  while (scanf("%d%d",&n,&m)==2)
   {
   	 if (!sg[n][m])
   	  printf("LOSE\n");
   	 else
   	  printf("WIN\n");
   }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值