bzoj 3048: [Usaco2013 Jan]Cow Lineup

3048: [Usaco2013 Jan]Cow Lineup

Time Limit: 2 Sec   Memory Limit: 128 MB
Submit: 123   Solved: 90
[ Submit][ Status][ Discuss]

Description

 Farmer John's N cows (1 <= N <= 100,000) are lined up in a row. Each cow is identified by an integer "breed ID" in the range 0...1,000,000,000; the breed ID of the ith cow in the lineup is B(i). Multiple cows can share the same breed ID. FJ thinks that his line of cows will look much more impressive if there is a large contiguous block of cows that all have the same breed ID. In order to create such a block, FJ chooses up to K breed IDs and removes from his lineup all the cows having those IDs. Please help FJ figure out the length of the largest consecutive block of cows with the same breed ID that he can create by doing this.

给你一个长度为n(1<=n<=100,000)的自然数数列,其中每一个数都小于等于10亿,现在给你一个k,表示你最多可以删去k类数。数列中相同的数字被称为一类数。设该数列中满足所有的数字相等的连续子序列被叫做完美序列,你的任务就是通过删数使得该数列中的最长完美序列尽量长。

Input

* Line 1: Two space-separated integers: N and K. 
* Lines 2..1+N: Line i+1 contains the breed ID B(i). 

Output


* Line 1: The largest size of a contiguous block of cows with identical breed IDs that FJ can create.

Sample Input

9 1
2
7
3
7
7
3
7
5
7

INPUT DETAILS: There are 9 cows in the lineup, with breed IDs 2, 7, 3, 7, 7, 3, 7, 5, 7. FJ would like to remove up to 1 breed ID from this lineup.

Sample Output

4

OUTPUT DETAILS: By removing all cows with breed ID 3, the lineup reduces to 2, 7, 7, 7, 7, 5, 7. In this new lineup, there is a contiguous block of 4 cows with the same breed ID (7).

HINT

样例解释:

  长度为9的数列,最多只能删去1类数。

  不删,最长完美序列长度为2.

  删去一类数3,序列变成2 7 7 7 7 5 7,最长完美序列长度为4.因此答案为4.

Source


题解:离散化+单调队列。orz

先把N个数离散化,然后开一个单调队列,用head,tail 两个指针,保证每个时刻,队列中数的种类都不超过m+1个,如果当前数在head-tail 中出现过,更新他所代表的值的个数,然后更新答案,如果加上这个数队列中的元素就超过了M+1,那么就把head指针向后移,直到head -tail中某个数的个数变成0,再加入当前数。

需要注意的是如果队列中元素种类的个数本身就小于等于m+1,那么直接扫一遍计算答案就好了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1000003
using namespace std;
int n,m,a[N],b[N],p[N],newn[N],cnt;
int q[N],key[N],pd[N];
struct data
{
 int pos,x;
}; data num[N];
int cmp(data x,data y)
{
  return x.x<y.x;
}
int main()
{
  freopen("lineup.in","r",stdin);
  freopen("lineup.out","w",stdout);
  scanf("%d%d",&n,&m);
  for (int i=1;i<=n;i++)
   scanf("%d",&num[i].x),num[i].pos=i;
  sort(num+1,num+n+1,cmp);
  cnt=0;
  cnt++; newn[num[1].pos]=cnt;
  for (int i=2;i<=n;i++)
   if (num[i].x!=num[i-1].x)
    cnt++,newn[num[i].pos]=cnt;
   else  newn[num[i].pos]=cnt;
  //cout<<cnt<<endl;
  m++; m=min(cnt,m);
  int head=1; int tail=1; int maxn=0;
  pd[tail]++; q[tail]=newn[tail]; key[newn[1]]++; maxn=1;
  while (head<=tail)
   {
   	 tail++;
     pd[tail]=pd[tail-1];
     if (pd[tail]>=m) break;
     if (!key[newn[tail]])   pd[tail]++;
     key[newn[tail]]++;  q[tail]=newn[tail];
     maxn=max(maxn,key[newn[tail]]);
   }
  while (head<=tail&&tail<=n)
  {
   while (key[newn[tail]]&&head<=tail) 
   {
   	 q[tail]=newn[tail];
   	 maxn=max(maxn,++key[newn[tail]]);
   	 tail++;
   }
   while (!key[newn[tail]]&&head<tail)
    {
      key[newn[head]]--; head++;
      if (!key[newn[head-1]]) 
	   {
	     key[newn[tail]]++; q[tail]=newn[tail];
	     maxn=max(maxn,key[newn[tail]]); tail++;
	     break;
	   }
    }
  }
  printf("%d\n",maxn);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值