poj 2369 Permutations(置换)

19 篇文章 0 订阅

Permutations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2926 Accepted: 1572

Description

We remind that the permutation of some final set is a one-to-one mapping of the set onto itself. Less formally, that is a way to reorder elements of the set. For example, one can define a permutation of the set {1,2,3,4,5} as follows: 
 
This record defines a permutation P as follows: P(1) = 4, P(2) = 1, P(3) = 5, etc. 
What is the value of the expression P(P(1))? It’s clear, that P(P(1)) = P(4) = 2. And P(P(3)) = P(5) = 3. One can easily see that if P(n) is a permutation then P(P(n)) is a permutation as well. In our example (believe us) 
 
It is natural to denote this permutation by P2(n) = P(P(n)). In a general form the defenition is as follows: P(n) = P1(n), Pk(n) = P(Pk-1(n)). Among the permutations there is a very important one — that moves nothing: 
 
It is clear that for every k the following relation is satisfied: (EN)k = EN. The following less trivial statement is correct (we won't prove it here, you may prove it yourself incidentally): Let P(n) be some permutation of an N elements set. Then there exists a natural number k, that Pk = EN. The least natural k such that Pk = EN is called an order of the permutation P. 
The problem that your program should solve is formulated now in a very simple manner: "Given a permutation find its order."

Input

In the first line of the standard input an only natural number N (1 <= N <= 1000) is contained, that is a number of elements in the set that is rearranged by this permutation. In the second line there are N natural numbers of the range from 1 up to N, separated by a space, that define a permutation — the numbers P(1), P(2),…, P(N).

Output

You should write an only natural number to the standard output, that is an order of the permutation. You may consider that an answer shouldn't exceed 10 9.

Sample Input

5
4 1 5 2 3

Sample Output

6

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:给出1-n的一个排列,a1,a2,...,an,P(1)=a1,P(2)=a2,...,P(n)=an,P(P(1))=P(a1),P(P(2))=P(a2),
...,P(P(n))=P(an).问经过多少次后使得P(1)=1,...,P(n)=n.求最少多少次,是序列变成一个有序的数列。

题解:置换。

其实相当于给出了一种置换的方式。那么我们可以求出每个轮换中数的个数,即一个轮换中交换多少次可以变成最初的样子,然后求出每个轮换的最小公倍数,即为答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 10003
using namespace std;
int ans,cnt[N],a[N],maxn,n,use[N];
int gcd(int x,int y)
{
	int r;
	while (y){
		r=x%y;
		x=y; 
		y=r;
	}
	return x;
}
int main()
{
	scanf("%d",&n);
	for (int i=1;i<=n;i++)
	 scanf("%d",&a[i]),cnt[a[i]]++,maxn=max(maxn,a[i]);
	for (int i=1;i<=n;i++)  cnt[i]=cnt[i]+cnt[i-1];
	int ans=1;
	for (int i=1;i<=n;i++)
	 if (!use[i]){
	 	int len=0; int j=i;
	 	while (!use[j]){
	 		len++; 
	 		use[j]=1; j=cnt[a[j]];
	 	}
	 	ans=(ans*len)/gcd(ans,len);
	 }
	printf("%d\n",ans);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值