SPF
Description
Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes. Sample Input 1 2 5 4 3 1 3 2 3 4 3 5 0 1 2 2 3 3 4 4 5 5 1 0 1 2 2 3 3 4 4 6 6 3 2 5 5 1 0 0 Sample Output Network #1 SPF node 3 leaves 2 subnets Network #2 No SPF nodes Network #3 SPF node 2 leaves 2 subnets SPF node 3 leaves 2 subnets Source |
[Submit] [Go Back] [Status] [Discuss]
题解:tarjan求割点。
这道题在求割点的基础上还需要求删去割点后连通块的数目。
我们再求割点的时候是用low[v[i]]>=dfsn[x]来判断的割点,如果满足条件那么就数目只有通过这个点才能到达某个连通块,所以这时满足上述条件的个数就是删去这个点会形成的连通块个数,为什么要+1呢?因为割点本身就是属于一个连通块的,但是这个他自己的连通块无法用来判断,所以没有计入答案。
但是需要注意就是1,也就是根节点,对于根节点来说,没有更新他的块,所以不用+1.
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 1003
#define M 500003
using namespace std;
int ins[N],dfsn[N],low[N],vis[N],pd[N],top,st[N],cnt,belong[N],subnets[N];
int point[M],next[M],v[M],n,m,ans[N],sz,tot,son;
void add(int x,int y)
{
tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y;
tot++; next[tot]=point[y]; point[y]=tot; v[tot]=x;
}
void tarjan(int x)
{
dfsn[x]=low[x]=++sz; ins[x]=1; st[++top]=x;
for (int i=point[x];i;i=next[i])
{
if (!dfsn[v[i]]) {
tarjan(v[i]);
low[x]=min(low[x],low[v[i]]);
if(low[v[i]]>=dfsn[x]) {
if(x!=1) subnets[x]++;
if(x==1) son++;
}
}
else if (ins[v[i]]) low[x]=min(low[x],dfsn[v[i]]);
}
}
int main()
{
freopen("a.in","r",stdin);
int sum=0;
while (true) {
sum++;
tot=0; cnt=0; sz=0; top=0;
memset(point,0,sizeof(point));
memset(next,0,sizeof(next));
memset(ans,0,sizeof(ans));
int t=0; n=0;
while (true) {
int x,y;
scanf("%d",&x); if (!x) break;
scanf("%d",&y); n=max(n,x); n=max(n,y);
add(x,y); t++;
}
if (!t) break;
printf("Network #%d\n",sum);
memset(dfsn,0,sizeof(dfsn));
memset(vis,0,sizeof(vis));
memset(ins,0,sizeof(ins)); sz=0; son=0;
memset(subnets,0,sizeof(subnets));
tarjan(1);
if (son>1) subnets[1]=son-1;
bool pd1=false;
for (int i=1;i<=n;i++) cout<<subnets[i]<<" ";
cout<<endl;
for (int i=1;i<=n;i++)
if (subnets[i]) printf(" SPF node %d leaves %d subnets\n",i,subnets[i]+1),pd1=true;
if (!pd1) printf(" No SPF nodes\n");
printf("\n");
}
}