hdu 2444 The Accomodation of Students (二分图判定+匈牙利算法)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5566    Accepted Submission(s): 2539


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2438  2443  2442  2441  2440 
 

Statistic |  Submit |  Discuss | Note

题解:二分图判定+匈牙利算法。

对图进行黑白染色(一条边的两个端点颜色必须不同),如果一个点被染了两种颜色,那么一定不是二分图。

匈牙利算法用来计算二分图的最大匹配,时间复杂度O(ve)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 403
using namespace std;
int point[N],nxt[N*N],v[N*N];
int belong[N],cur[N],n,m,vis[N],col[N],tot;
bool pd;
void add(int x,int y)
{
	tot++; nxt[tot]=point[x]; point[x]=tot; v[tot]=y;
	tot++; nxt[tot]=point[y]; point[y]=tot; v[tot]=x;
}
void dfs(int x,int mark)
{
	col[x]=mark;
	for (int i=point[x];i;i=nxt[i])
	{
	 if (col[v[i]]==-1)  dfs(v[i],mark^1);
	 else if (col[v[i]]!=mark^1) {
	 	pd=false;
	 	return;
     }
	}
}
bool find(int x,int k)
{
	for (int i=point[x];i;i=nxt[i])
	 {
	 	if (cur[v[i]]==k) continue;
	 	cur[v[i]]=k;
	 	if(!belong[v[i]]||find(belong[v[i]],k)) {
	 		belong[v[i]]=x;
	 		return true;
		 }
	 }
	return false;
}
int main()
{
	while (scanf("%d%d",&n,&m)!=EOF) {
		tot=0; 
		if (n==1) {
			printf("No");
			continue;
		}
		memset(nxt,0,sizeof(nxt));
		memset(point,0,sizeof(point));
		for (int i=1;i<=m;i++) {
			int x,y; scanf("%d%d",&x,&y);
			add(x,y);
		}
		memset(belong,0,sizeof(belong));
		memset(vis,0,sizeof(vis));
		memset(cur,0,sizeof(cur)); pd=true;
		memset(col,-1,sizeof(col));
		for (int i=1;i<=n;i++)
		 if (col[i]==-1)  dfs(i,0);
		if (!pd) {
			printf("No\n");
			continue;
		}
		int ans=0;
		for (int i=1;i<=n;i++) 
		 if (find(i,i)) ans++;
		printf("%d\n",ans/2);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值