bzoj 4579: [Usaco2016 Open]Closing the Farm (并查集+离线)

4579: [Usaco2016 Open]Closing the Farm

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 113   Solved: 69
[ Submit][ Status][ Discuss]

Description

Farmer John and his cows are planning to leave town for a long vacation, and so FJ wants to temporar
ily close down his farm to save money in the meantime.The farm consists of NN barns connected with M
M bidirectional paths between some pairs of barns (1≤N,M≤200,000). To shut the farm down, FJ plans
 to close one barn at a time. When a barn closes, all paths adjacent to that barn also close, and ca
n no longer be used.FJ is interested in knowing at each point in time (initially, and after each clo
sing) whether his farm is "fully connected" -- meaning that it is possible to travel from any open b
arn to any other open barn along an appropriate series of paths. Since FJ's farm is initially in som
ewhat in a state of disrepair, it may not even start out fully connected.

Input

The first line of input contains N and M. The next M lines each describe a path in terms of the pair
 of barns it connects (barns are conveniently numbered 1…N). The final N lines give a permutation o
f 1…N describing the order in which the barns will be closed.

Output

The output consists of N lines, each containing "YES" or "NO". The first line indicates whether the 
initial farm is fully connected, and line i+1 indicates whether the farm is fully connected after th
e iith closing.

Sample Input

4 3
1 2
2 3
3 4
3
4
1
2

Sample Output

YES
NO
YES
YES

HINT

Source

[ Submit][ Status][ Discuss]

题解:并查集+离线

删边不好实现,所以将询问离线,倒着向图中加边,然后用并查集维护连通性并记录集合中的元素个数,如果集合中的元素个数恰好等于此时图中的点数,就输出YES.

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#define N 400003
using namespace std;
int point[N],next[N],v[N],vis[N],n,m;
int tot,a[N],pd[N],fa[N],sum[N];
void add(int x,int y)
{
	tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y;
	tot++; next[tot]=point[y]; point[y]=tot; v[tot]=x;
}
int find(int x)
{
	if (fa[x]==x) return x;
	fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	freopen("closing.in","r",stdin);
	freopen("closing.out","w",stdout);
	scanf("%d%d",&n,&m);
	for (int i=1;i<=m;i++){
		int x,y; scanf("%d%d",&x,&y);
		add(x,y);
	}
	for (int i=1;i<=n;i++) scanf("%d",&a[i]);
	for (int i=1;i<=n;i++) fa[i]=i,sum[i]=1;
	for (int i=n;i>=1;i--){
		vis[a[i]]=1; int x=a[i];  int r1=find(x);
		for (int j=point[x];j;j=next[j])
		 if (vis[v[j]]) {
		 	int r2=find(v[j]);
		 	if (r2!=r1) {
		 		fa[r2]=r1;
		 		sum[r1]+=sum[r2];
			 }
		 }
		if (sum[r1]!=n-i+1) pd[i]=0;
		else pd[i]=1;
	}
	for (int i=1;i<=n;i++) 
	 if (pd[i]) printf("YES\n");
	 else printf("NO\n");
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值