hdu 1814 Peaceful Commission (2-SAT)

Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3355    Accepted Submission(s): 1101


Problem Description
The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task
Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.
 

Input
In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.
 

Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.
 

Sample Input
  
  
3 2 1 3 2 4
 

Sample Output
  
  
1 4 5
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   1815  1816  3062  1811  1817 
 

Statistic |  Submit |  Discuss | Note

题解:2-SAT

如果x,y之间有边,那么x,y不能同时入选,也就是选了x必然要选y',选了y必然要选x'

初始时所有的标记都是-1.从编号小的节点开始尝试,将当前尝试节点x都标记为1,x'标记为0,然后对于他的后继节点进行标记,如果后继节点没有标记,则标记为1。如果标记是1,说明这个强连通分量遍历结束,并且可行。如果标记为0,则说明存在节点x,x'在同一个强连通分量中,发生冲突,当前尝试不合法,需要将标记撤回,从最开始节点的对立点继续进行尝试。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
#define N 50003
using namespace std;
int n,m,cnt;
int point[N],v[N],nxt[N],col[N],q[N],tot;
void add(int x,int y)
{
	tot++; nxt[tot]=point[x]; point[x]=tot; v[tot]=y;
}
bool dfs(int x)
{
	if (col[x]==1) return true;
	if (col[x]==0) return false;
	q[++cnt]=x;
	col[x]=1; col[x^1]=0;
	for (int i=point[x];i;i=nxt[i])
	 if (!dfs(v[i])) return false;
	return true;
}
bool solve()
{
	for (int i=0;i<2*n;i++) {
		cnt=0;
		if (!dfs(i)) {
			for (int j=1;j<=cnt;j++) {
				int t=q[j];
				col[t]=-1; col[t^1]=-1;
			}
			if (!dfs(i^1)) return false;
		}
	}
	return true;
}
int main()
{
	freopen("a.in","r",stdin);
	while (scanf("%d%d",&n,&m)!=EOF){
		tot=0;
		memset(col,-1,sizeof(col));
		memset(point,0,sizeof(point));
		for (int i=1;i<=m;i++) {
			int x,y; scanf("%d%d",&x,&y);
			x--; y--;
			add(x,y^1); add(y,x^1);
		}
		if (solve()){
			for (int i=0;i<2*n;i++)
			 if (col[i]==1) printf("%d\n",i+1);
			continue;
		}
		printf("NIE\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值