S - Spiderman POJ - 1925 (区间动态规划)

S - Spiderman

 POJ - 1925 

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web. 

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards. 


You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4

Sample Output

3
-1

 区间动态规划,因为蜘蛛侠每次吐蜘蛛网都是在一个直线上(y=公寓的高度),我们定义dp[i]为到x坐标为i的地方吐的最少的次数,然后从左往右dp每个建筑的有效区域,dp[p[i].x+j]=min{dp[p[i].x-j]+1}, j的值为蜘蛛侠可以向该建筑吐蜘蛛网的情况下距离该建筑的x方向的距离

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=5010;
const int nmax=110;
const double esp = 1e-9;
const double PI=3.1415926;
int nor[N][N],west[N][N],dp[1000010];
struct point
{
    ll x,y;
} p[N];
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%lld%lld",&p[i].x,&p[i].y);
        memset(dp,inf,sizeof(dp));
        dp[p[0].x]=0;  //初始条件
        for(int i=1; i<n; i++)
        {
            int d=sqrt(1.0*p[i].y*p[i].y-(p[i].y-p[0].y)*(p[i].y-p[0].y));  
            //p[i].y要定义为long long 型,否则p[i].y*p[i].y溢出
            for(int j=1; j<=d; j++)
            {
                if(p[i].x-j<p[0].x)
                    break;  //剪枝
                if(dp[p[i].x-j]==inf)
                    continue;  //上一个出网点不存在
                int next=min(p[i].x+j,p[n-1].x);
                dp[next]=min(dp[next],dp[p[i].x-j]+1);
            }
        }
        if(dp[p[n-1].x]==inf)
            printf("-1\n");  
        else
            printf("%d\n",dp[p[n-1].x]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值