1001. Alphacode

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: “Let’s just use a very simple code: We’ll assign A' the code word 1,B’ will be 2, and so on down to Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the wordBEAN’ encoded as 25114. You could decode that in many different ways!” Alice: “Sure you could, but what words would you get? Other than BEAN', you'd getBEAAD’, YAAD',YAN’, YKD' andBEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN’ anyway?” Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.” Alice: “How many different decodings?” Bob: “Jillions!” For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0’ will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0
Sample Output

6
89
1

思路:
这道题可以用动态规划的思想来解决,例如,对于字符串s, 它的前i个数字翻译出来的字符串总数,由两种情况决定,第一种是由s[i-1]和s[i]这两位数字联合起来翻译的种数m, 第二种是由s[i]翻译出来的种数n,而解就是m+n。所以只要顺推一遍就可以了.

注意:
(1)对于0的处理,例如数字为101时,只能分为10,1;而不能分为1,01。
(2)在顺推过程中,要进行分类,如果两个数字凑在一起大于26,那么就不能把他们分在一起了。

代码如下:

#include<iostream>
#include<cstring>

using namespace std;

int main()
{
    string s;
    while(cin>>s)
    {
        if(s=="0")
            break;
        int m=0,n=1;//m表示后两个数字组合在一起翻译成字符串的个数,n最后一个数字单独翻译的种数。 
        for(int i=1;i<s.size();i++)
        {
            if(s[i]=='0')
            {
                m=0;
                i++;
            }
            else if(s[i-1]>'2'||(s[i-1]=='2'&&s[i]>'6'))
            {
                n=m+n;
                m=0;
            }
            else
            {
                int temp=n;
                n=m+n;
                m=temp;
            }
        }
        cout<<m+n<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值