POJ 3190 - Stall Reservations(贪心)

8 篇文章 0 订阅

Stall Reservations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2278 Accepted: 811 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

============================

题意:求使给出的线段互相不重合所需要的最小行数


通过这题学会了优先队列。优先队列用结构体的话需要在结构体里重载' < ' ,默认是最大值在队首。要想每次取出的是最小值,就在重载' < '时定义为大于。具体看代码

先以左端点为关键字进行排序。优先队列中存的是已经定位的线段,找出右端点最小的,看是否小于当前线段的左端点。若小于则弹出该线段,当前线段加入优先队列;若大于等于,则另开新行,当前线段加入优先队列。


#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>

using namespace std;

struct cow
{
    int st,ed;
    int p;
    bool operator<(const cow& rhs) const //重载
    {
        return ed>rhs.ed; //可取出右端点最小的。若改成'<'则取出右端点最大的。
    }
}a[51111];

bool cmp(cow a,cow b)
{
    return a.st<b.st;
}

int main()
{
    int n,num[51111],sz=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&a[i].st,&a[i].ed);
        a[i].p=i;
    }
    sort(a+1,a+n+1,cmp);
    priority_queue<cow>que;
    num[a[1].p]=++sz;
    que.push(a[1]);
    for(int i=2;i<=n;i++)
    {
        cow temp=que.top();
        if(temp.ed<a[i].st)
        {
            num[a[i].p]=num[temp.p];
            que.pop();
            que.push(a[i]);
        }
        else
        {
            num[a[i].p]=++sz;
            que.push(a[i]);
        }
    }
    printf("%d\n",sz);
    for(int i=1;i<=n;i++)
        printf("%d\n",num[i]);

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值