POJ 1328 - Radar Installation(贪心)

8 篇文章 0 订阅

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45932 Accepted: 10256

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

====================

题意:在沿海(x轴)放置雷达,雷达侦测半径为d,求使给出的n个小岛全部被覆盖所需要的最少的雷达数量


先求出使每个小岛可侦测的区间,即以小岛为圆心半径为d的圆与x轴的交点之间的部分,就是对于该小岛来说可放置雷达的范围。若没有交点直接输出-1。

求出每个小岛的区间之后就是标准的贪心了


#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;

struct radar
{
    double x,y;
    double l,r;
}a[1111];

bool cmp(radar a,radar b)
{
    return a.r<b.r;
}

int main()
{
    int n,d,T=1;
    while(~scanf("%d%d",&n,&d))
    {
        if(n==0&&d==0) break;
        printf("Case %d: ",T++);
        int ok=0;
        for(int i=0;i<n;i++)
            scanf("%lf%lf",&a[i].x,&a[i].y);
        for(int i=0;i<n;i++)
        {
            if(a[i].y>d)
            {
                printf("-1\n");
                ok=1;
                break;
            }
            a[i].l=a[i].x-sqrt(d*d-a[i].y*a[i].y);
            a[i].r=a[i].x+sqrt(d*d-a[i].y*a[i].y);
        }
        if(ok) continue;
        sort(a,a+n,cmp);
        double temp=a[0].r;
        int ans=1;
        for(int i=1;i<n;i++)
        {
            if(a[i].l>temp)
            {
                ans++;
                temp=a[i].r;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值