uva 10387 - Billiard

Problem A: Billiard

In a billiard table with horizontal side  a  inches and vertical side  b  inches, a ball is launched from the middle of the table. After  s  > 0 seconds the ball returns to the point from which it was launched, after having made  m  bounces off the vertical sides and  n  bounces off the horizontal sides of the table. Find the launching angle  A  (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are:  a b s m , and  n , respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle  A  in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81


============================


a*m为水平方向走过的距离,b*n为竖直方向走过的距离,勾股定理得到的斜边即为总路程

除以时间s得到初速度v,角度tan(angle)=(b*n)/(a*m)

atan得到的是弧度数而不是角度数需要转换


#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>

using namespace std;

const double pi=acos(-1.0);

int main()
{
    double a,b,s,m,n,v,angle;
    while(~scanf("%lf%lf%lf%lf%lf",&a,&b,&s,&m,&n))
    {
        if(a==0&&b==0&&s==0&&m==0&&n==0)
            break;
        v=sqrt((a*m)*(a*m)+(b*n)*(b*n))/s;
        angle=atan(b*n/(a*m))/pi*180;
        printf("%.2lf %.2lf\n",angle,v);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值