UVA 10361 - Automatic Poetry(字符串)

Automatic Poetry

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

 

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

 

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

 

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

 

Ein Kind halt seinen Schnabel nur,

wenn es hangt an der Nabelschnur.        

 

/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

 

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5

 

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen <schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur <>oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist


TUD Programming Contest


===================================

s1<s2>s3<s4>s5

第一句去掉<>输出,第二句…的地方用s4s3s2s5替换


看了下别人写的代码学习学习……

写一个函数判断第一句的五个字符串的终止位置,分别得到这五个字符串再输出,第二句就直接把最后三个字符替换掉


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

void getstr(char str[])
{
    for(int i=0;i<111;i++)
    {
        char c=getchar();
        if(c!='<'&&c!='>'&&c!='\n')
            str[i]=c;
        else
        {
            str[i]='\0';
            return;
        }
    }
}

int main()
{
    int t;
    char s1[111],s2[111],s3[111],s4[111],s5[111],s[111];
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        getstr(s1);getstr(s2);getstr(s3);getstr(s4);getstr(s5);
        gets(s);
        s[strlen(s)-3]='\0';
        cout<<s1<<s2<<s3<<s4<<s5<<endl;
        cout<<s<<s4<<s3<<s2<<s5<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值