个人赛---贪心问题

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit


题目大意:

MS Inc.  公司要统计全年的盈利状况,每个月如果有盈余,则盈余为s;如果有赤字,则赤字为d。公司每五个月进行一次统计,共统计八次,分别为1-5、2-6、3-7、4-8、5-9、6-10、7-11、8-12,且八次都为亏损。输入s和d(每月盈余和 赤字的数额,且每月的都相同),判断全年是否能有盈余,如果能,则输出盈余的最大值;如果不能,则输出Drficit。

解题思路:

因为八次都是亏损,且要保证尽量有盈余,所以可以分为5种情况:

1) ssssd,一年ssssdssssdss,10*s-2*d,若大于零则盈利,否则亏损。

2) sssdd,一年sssddsssddss,8*s-4*d,若大于零则盈利,否则亏损。

3) ssddd,一年ssdddssdddss,6*s-6*d,若大于零则盈利,否则亏损。

4) sdddd,一年sddddsddddsd,3*s-9*d,若大于零则盈利,否则亏损。

5) ddddd,一年dddddddddddd,一定亏损。



代码实现:

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;

int main()
{
    int s, d, m[20];                                                                               //m数组表示月份,记录这个月是有盈余还是有赤字
    while (scanf("%d%d",&s,&d)!=EOF)
    {
        memset(m, 0, sizeof(m));
        int sums = 0;
        int sumd = 0;
        for (int i = 0; i < 8; i++)
        {
            while (!0)
            {
                sumd = m[i] + m[i + 1] + m[i + 2] +m[i + 3] + m[i + 4];       //连续五个月中有赤字的月的个数
                sums = 5 - sumd;                                                              //连续五个月中有盈余的个数
                if (sums * s >= sumd * d)
                {
                    for (int j = i + 4; j >= 0; j--)
                    {
                        if (m[j] != 1)
                        {
                            m[j] = 1;
                            break;
                        }
                    }
                }
                else
                    break;
            }
        }
        sumd = 0;
        for (int i = 0; i < 12; i++)                                                                //计算12个月中有赤字的个数
        {
            sumd += m[i];
        }
        sums = 12 - sumd;
        int cnt = sums * s - sumd * d;
        if (cnt > 0)
            printf("%d\n", cnt);
        else
            printf("Deficit\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值