POJ1050-矩阵压缩

To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52454 Accepted: 27741

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

题目大意是给定一个矩阵数组,求其子矩阵和的最大值。

这道题有两个关键点:

一是如何求一维数组的最大子序列和;

二是把题目中的二维数组按行压缩成一维数组,接下来就按一维数组的方法做就可以了,这是关键部分的代码:

for(int i=0;i<n;i++)
        {
            for(int j=i;j<n;j++)
            {
                memset(b,0,sizeof(b));
                int tmp=0;
                int sum=-123123123;//每判断完一次b数组一定要初始化一下。
                for(int k=0;k<n;k++)
                {
                    for(int t=i;t<=j;t++)
                    {
                        b[k]+=a[t][k];
                    }
                    if(tmp>0)
                        tmp+=b[k];
                    else
                        tmp=b[k];//这里我一开始写的是判断b[k]是否大于零,并令b[k]<=0时tmp为0,后来发现如果b[k]全为负数时完全无法计算出正确的值,才改成了这种正确的判断方法。
                    if(tmp>sum)
                        sum=tmp;
                }
                if(sum>max)
                    max=sum;
            }
        }

代码如下:

#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int a[101][101];
int b[101];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		int max=-123123123;
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				scanf("%d",&a[i][j]);
		for(int i=0;i<n;i++)
		{
			for(int j=i;j<n;j++)
			{
				memset(b,0,sizeof(b));
				int tmp=0;
				int sum=-123123123;
				for(int k=0;k<n;k++)
				{
					for(int t=i;t<=j;t++)
					{
						b[k]+=a[t][k];
					}
					if(tmp>0)
						tmp+=b[k];
					else
						tmp=b[k];
					if(tmp>sum)
						sum=tmp;
				}
				if(sum>max)
					max=sum;
			}
		}
		printf("%d\n",max);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值