poj1050(压缩矩阵)(dp)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39200 Accepted: 20706

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

题意:

给出一组矩阵,要求求出矩阵中的最大子矩阵;

思路:

将每组矩阵子矩阵的值求出存在临时矩阵中然后对子矩阵的值求和,设一个最大值,于和比较求的最大的子矩阵的值:

代码:

#include <iostream>
#include<string>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
int temp[105],m,n;
int getnum()
{
    int sum=0,max1=0;
    for(int i=0;i<n;i++)
    {
        sum+=temp[i];
        if(sum>max1)max1=sum;
        if(sum<0)sum=0;
    }
    return max1;
}
int main()
{
    int t,dp[105][105];
    while(cin>>n)
    {
        m=n;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            cin>>dp[i][j];
        int sum1=-1000;       //结果可能为负值所以需要初始无穷小;
        for(int k=0;k<n;k++)
        {
            memset(temp,0,sizeof(temp));
            for(int i=k;i<n;i++)
            {
                for(int j=0;j<n;j++)
                    temp[j]+=dp[i][j];
                int ans=getnum();
                if(ans>sum1)
                    sum1=ans;
            }
        }
        cout<<sum1<<endl;

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值