Hdu——1113 Word Amalgamation

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1660    Accepted Submission(s): 766


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. 
 

Input
The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. 
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

为了提高匹配的效率,将字典按单词长度分为了6组,这样根据 scrambled words的长度,到相应的组里匹配。匹配的过程,先用哈希映射统计出字符串中出现的字符种类和每种字符的数量,再比对所得的两个字符串的字符信息。

#include <iostream>
#include <string>
#include <memory>
#include <algorithm>

using namespace std;

int num[7];
string dic[7][100];

bool cmp(const string &a, const string &b)
{
	for (int i = 0; i < a.length(); i++)
	{
		if (a[i] != b[i])
		{
			return a[i] < b[i];
		}
	}
	return false;
}

void CountLetter(string &str, int *count)
{
	for (int i = 0; i < str.length(); i++)
	{
		count[str[i] - 'a']++;
	}
}

bool Matching(int *a, int *b)
{
	for (int i = 0; i < 26; i++)
	{
		if (a[i] != b[i])
		{
			return false;
		}
	}
	return true;
}

int main()
{
	int i, len;
	int scrambled[26], word[26];
	bool flag;

	memset(num, 0, sizeof(num));
	while (cin>>dic[0][0])
	{
		if (dic[0][0] == "XXXXXX")
		{
			break;
		}
		len = dic[0][0].length();
		dic[len][num[len]++] += dic[0][0];
	}
	for (i = 1; i < 7; i++)
	{
		sort(dic[i], dic[i]+num[i], cmp);
	}

	while (cin>>dic[0][0])
	{
		if (dic[0][0] == "XXXXXX")
		{
			break;
		}
		memset(scrambled, 0, sizeof(scrambled));
		CountLetter(dic[0][0], scrambled);

		len = dic[0][0].length();
		flag = false;
		for (i = 0; i < num[len]; i++)
		{
			memset(word, 0, sizeof(word));
			CountLetter(dic[len][i], word);
			if (Matching(word, scrambled))
			{
				flag = true;
				cout<<dic[len][i]<<endl;
			}
		}
		if (!flag)
		{
			cout<<"NOT A VALID WORD"<<endl;
		}
		cout<<"******"<<endl;
	}
	return 0;
}

#include <iostream>
#include <map>
#include <string>
#include <algorithm>

using namespace std;

int main()
{
	map<string, string> dict;
	string word, index;
    bool flag;
	while (cin>>word && word != "XXXXXX")
	{
		//原单词作为放在map的索引位置,即first,map会自动按字典序排列
		//原单词内部按字典序排序后作为之后查找时的索引值
		index = word;
		sort(index.begin(), index.end());
		dict[word] = index;
	}
	while (cin>>word && word != "XXXXXX")
	{
		flag = false;
		sort(word.begin(), word.end());
		for (map<string, string>::iterator it = dict.begin(); it != dict.end(); it++)
		{
			if (it->second == word)
			{
				cout<<it->first<<endl;
				flag = true;
			}
		}
		if (!flag)
		{
			cout<<"NOT A VALID WORD"<<endl;
		}
		cout<<"******"<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 5522 Accepted: 2789 Description In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. Input The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. Output For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list. Sample Input tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX Sample Output score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ****** Source Mid-Central USA 1998
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

庞老板

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值