贪心算法——Hdu 1050 Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12304    Accepted Submission(s): 4226


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30

需要注意的是房间与走廊的位置关系,就如图中所给的图片所示


相对门的两个房间占用同一处走廊,所以例如有1——3和4——6移动方式时,它们是共享了同一段走廊的,即3号房间门前的走廊。

分析过程有如下图所示



代码一

#include <cstdio>
#include <algorithm>

using namespace std;

#define SIZE 205

struct Data_Type
{
	int from, to;
	bool flag;
}moving[SIZE];

bool Cmp(const Data_Type a, const Data_Type b)
{
	return a.from < b.from;
}

int main(void)
{
	int i, testNum, n;

	scanf("%d", &testNum);
	while (testNum-- != 0)
	{
		scanf("%d", &n);
		for (i = 0; i < n; i++)
		{
			scanf("%d%d", &moving[i].from, &moving[i].to);
			if (moving[i].from > moving[i].to)
			{
				int temp = moving[i].from;
				moving[i].from = moving[i].to;
				moving[i].to = temp;
			}
			if (moving[i].from % 2 == 0)
			{
				moving[i].from--;
			}
			if (moving[i].to % 2 == 1)
			{
				moving[i].to++;
			}
			moving[i].flag = false;
		}
		sort(moving, moving+n, Cmp);
		bool completion = false;
		int count = -1, priorTo;
		while (!completion)
		{
			completion = true;
			count++;
			priorTo = 0;
			for (i = 0; i < n; i++)
			{
				if (!moving[i].flag && moving[i].from > priorTo)
				{
					moving[i].flag = true;
					priorTo = moving[i].to;
					completion = false;
				}
			}
		}
		printf("%d\n", count*10);
	}
	return 0;
}

代码二


#include <stdio.h>
#include <string.h>

#define SIZE 405

int main(void)
{
	int count[SIZE];
	int i, j, testNum, n, max, from, to;

	scanf("%d", &testNum);
	while (testNum-- != 0)
	{
		scanf("%d", &n);
		memset(count, 0, sizeof(count));
		for (i = 0; i < n; i++)
		{
			scanf("%d %d", &from, &to);
			if (from > to)
			{
				int temp = from;
				from = to;
				to = temp;
			}
			if (from % 2 == 0)
			{
				count[from-1]++;
			}
			if (to % 2 == 1)
			{
				count[to+1]++;
			}
			for (j = from; j <= to; j++)
			{
				count[j]++;
			}
		}
		max = 0;
		for (i = 0; i < SIZE; i++)
		{
			if (count[i] > max)
			{
				max = count[i];
			}
		}
		printf("%d\n", max*10);
	}
	return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

庞老板

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值