二叉树的应用-----前序中序 推 后序

Tree

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB
上传者
苗栋栋


思路:前序是根左右 , 中序是左根右, 后序是左右根。
           举个例子:前序:DBACEGF 
                             中序:ABCDEFG
            那么前序中的D是后序中的最后一个,D在中序中位置是下标3,D的右面是EFG,再回到前序,E是后序中的倒数第               二个,以此类推!发现把大问题分成小问题后,操作思路不变,故考虑递归;
代码:
#include <stdio.h>
#include <string.h>

void travel(char pre[], char in[], int n){
	int i;
	if ( n > 0){
		i = 0;
		while(in[i] != pre[0])     //寻找根在中序中的位置
		   i ++;
		   travel(pre+1, in, i);   //递归调用 
		   travel(pre+1+i, in+i+1, n-i-1); //
		   printf("%c",pre[0]); 
	}
}
int main(void){
	char pre[26], inord[26];
	while(scanf("%s%s",pre,inord) != EOF){
		int len = strlen(pre);
		travel(pre, inord, len);
		printf("\n");
	}
	return 0;
} 

表明每次调用的代码:
#include <stdio.h>
#include <string.h>
int k = 0;
void travel(char pre[], char in[], int n){
	int i;    printf("%d\n", ++k);
	           printf("n = %d\n",n) ;
	if ( n > 0){	
		i = 0;
		while(in[i] != pre[0])
		   i ++;    printf("travel(pre+1, in, i)=travel(%s,%s,%d)\n",pre+1,in,i);
	    travel(pre+1, in, i); printf("travel(pre+1+i, in+i+1, n-i-1)=travel(%s,%s,%d)\n",pre+1+i,in+i+1,n-i-1);
		travel(pre+1+i, in+i+1, n-i-1);
		printf("!!%c!!",pre[0]); 
	}
}
int main(void){
	char pre[26], inord[26];
	while(scanf("%s%s",pre,inord) != EOF){
		int len = strlen(pre);
		travel(pre, inord, len);
		printf("\n");
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值