括号匹配,栈的基本应用;

样题:

Brackets! Brackets!
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 811(283 users)Total Accepted: 333(256 users)Rating: Special Judge: No
Description

There are six kinds of brackets: ‘(‘, ‘)’, ‘[‘, ‘]’, ‘{’, ‘}’. dccmx’s girl friend is now learning java programming language, and got mad with brackets! Now give you a string of brackets. Is it valid? For example: “(([{}]))” is valid, but “([)]” is not.

Input

First line contains an integer T (T<=10): the number of test case.

Next T lines, each contains a string: the input expression consists of brackets.

The length of a string is between 1 and 100.

Output

For each test case, output “Valid” in one line if the expression is valid, or “Invalid” if not.

Sample Input
2
{{[[(())]]}}
({[}])
Sample Output
Valid
Invalid



这是典型的栈的基础应用--括号匹配;
详细思路在代码注释里;


#include <stdio.h>
#include<algorithm>
#include<string.h>
#include<stack>
#include<iostream>
using namespace std;
int main()
{
    char c[1000];
    int n,i,d = 1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",&c);
        int str = strlen(c);
        stack<char> st;
        for(i = 0; i < str; i++)
        {
            if(c[i] == '(' || c[i] == '{'||c[i] == '[')
                st.push(c[i]);
            else if(c[i]==')'&&!st.empty()&&st.top()=='(')///遇到右括号时,当栈不为空时,栈首一定是'(';
                st.pop();///左括号找到匹配的,可以弹出;
            else if(c[i]==')'&&!st.empty()&&st.top()!='(')///这是不符合规则的,做一个标记;
                d=0;
            else if(c[i]==')'&&st.empty())///这是判断有没有没出现左括号,就有右括号的情况;
                d=0;///因为入栈的只能是左括号;
            else if(c[i] == ']'&&!st.empty()&&st.top()=='[')
                st.pop();
            else if(c[i] == ']'&&!st.empty()&&st.top()!='[')
                d=0;
            else if(c[i]==']'&&st.empty())
                d=0;
            else if(c[i]=='}'&&!st.empty()&&st.top()=='{')
                st.pop();
            else if(c[i]=='}'&&!st.empty()&&st.top()!='{')
                d=0;
            else if(c[i]=='}'&&st.empty())
                d=0;
        }
        if(!st.empty()||d == 0)///必须要弹尽栈里的元素,且不能有不符合规则的;
            printf("Invalid\n");
        else
            printf("Valid\n");
        d = 1;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值