堆应用 Fence Repair

题目介绍Fence Repair

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

这个题目的意思就是切割多大的木板需要付多少钱,需求的木板长度会在最初给你,求切割出这个木板来最少付的钱,也就是说,这个题最开始我是犯了一个错误的,最开始想当然的以为只需要减去木板中需求的最长的,然后将剩下的木板的长度作为花费加入总花费求和便是需求的最小的,实际上这样是不行的。对于为啥不可以我还没有研究出来,希望有人可以告诉我。

但是这个题显然可以这样想,每次切割都只能切割为两部分,所以完全可以将其理解为一个最有二叉树问题,及霍夫曼算法,即每次都找两个最小的相加,合并为一个新的节点继续相加,这样的话,将每个节点的权值相加便是最终要求的和,这样的话,显然求出来的便是正确结果。

AC代码:

#include<cstdio>
#include<queue>
#include<vector>
using namespace std;

int main()
{
	priority_queue<long long int,vector<long long int>,greater<long long int>> pi;
	long long int n,length=0,k,i,sum=0;
	scanf("%lld",&n);
	for(i=0;i<n;i++)
	{
		scanf("%lld",&k);
	
		pi.push(k);
	}
	
	while(pi.size()>=2)
	{
	    length=pi.top();
	    pi.pop();
	    length=length+pi.top();
	    pi.pop();
	    sum=sum+length;
	    pi.push(length);
	}
	printf("%lld",sum);
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值