If We Were a Child Again(大数除法、求余)

Description

       

“Oooooooooooooooh!         

If I could do the easy mathematics like my school days!!         

I can guarantee, that I’d not make any mistake this time!!”         

Says a smart university student!!         

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”         

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.         

          

         

The Problem

          

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.         

          

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

           

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).         

          

           
Output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

          

           
           
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

          

          

          

          

          
          
Sample Output

1

9

1

2147483646

 

         

         

         



 
#include <stdio.h>
#include <string.h>

void chu (char *p,unsigned long long b);
void yu (char *p,unsigned long long b);

int a[1000000];

int main()
{
    static char str[1000000];
    unsigned long long b = 0,t = 0;
    char c = ' ';

    while (scanf ("%s",&str) != EOF)
    {
        do
        {
            c = getchar ();
        }
        while (c != '/' && c != '%');

        scanf ("%llu",&b);

        if (c == '/')
        {
            chu (str,b);
        }
        else if (c == '%')
        {
            yu (str,b);
        }

    }

    return 0;
}

void chu (char *p,unsigned long long b)
{
    int *p1 = a;
    unsigned long long tmp = b,shang = 0,yu = 0;
    unsigned long long quan = 1,i = 0;
    int tf = 1,pritf = 0;

    while (*p != '\0')
    {
        *p1 = (int)(*p - '0');
        p1++;
        p++;
    }
    *p1 = 10;
    p1 = a;

    while (*p1 != 10)
    {
        yu = yu * 10;
        yu += *p1;
        shang = yu / b;
        yu %= b;

        if (shang != 0 && tf)
        {
            printf ("%llu",shang);
            tf = 0;
            pritf = 1;
        }else
        {
            if (!tf)
                printf ("%llu",shang);
        }

        p1++;
    }

    if (!pritf)
        printf ("0");
    printf ("\n");
}

void yu (char *p,unsigned long long b)
{
    int *p1 = a;
    unsigned long long tmp = b,shang = 0,yu = 0;
    unsigned long long quan = 1,i = 0;
    int tf = 1;

    while (*p != '\0')
    {
        *p1 = (int)(*p - '0');
        p1++;
        p++;
    }
    *p1 = 10;
    p1 = a;

    while (*p1 != 10)
    {
        yu = yu * 10;
        yu += *p1;
        shang = yu / b;
        yu %= b;
        p1++;
    }
    printf ("%llu\n",yu);
}

这是第一次接触大数的问题,C中没有数据类型可以把这么长的数据储存,所以,需要用字符串或者整形数组来分段储存,在其运算过程中,也需要考虑分段计算的问题。
当所有大数考虑到了,那么就需要考虑特殊情况了,比如求余为本身,求商为0,类似的特殊情况。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值