在weblogic8.1中部署axis 应用出现的问题

webservice8.1中部署axis webservice,经常会出现类似以下的错误

 

<2005-3-2 下午072705 CST> <Error> <HTTP> <BEA-101017> <[ServletContext(id=

3449288,name=testwebservice,context-path=/testwebservice)] Root cause of Servlet

Exception.

java.lang.IncompatibleClassChangeError

        at org.apache.axis.message.MessageElement.addTextNode(MessageElement.jav

a:1027)

        at org.apache.axis.message.SOAPHandler.endElement(SOAPHandler.java:121)

        at org.apache.axis.encoding.DeserializationContextImpl.endElement(Deseri

alizationContextImpl.java:1060)

        at weblogic.apache.xerces.parsers.AbstractSAXParser.endElement(AbstractS

AXParser.java:585)

        at weblogic.apache.xerces.impl.XMLNamespaceBinder.handleEndElement(XMLNa

mespaceBinder.java:898)

……

 

这是由于webservice8.1中所带的webservices.jaraxis中的saaj.jar冲突引起的,解决方法有两个:

1.  配置weblogic.xml,强制weblogic首先加载应用WEB-INF中的class

2.  修改startweblogic.cmd,将axis下的saaj.jar的路径放在weblogicwebservices.jar之前。

 

 

详细内容见:http://ws.apache.org/axis/java/install.html#depend

阅读更多
想对作者说点什么? 我来说一句

weblogic 8.1部署应用程序(图解)

2010年05月16日 1.35MB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭