Uva 10340 - All in All

All in All

You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes

题目比较简单,题意大致是给定两个字符串s,t,如果s的字母在t中都出现了,并且是按照s的正序排列的,则输出YES
这题需要注意的是循环控制,如果不对第二个字符串t进行处理将会超时,我这里定义了一个m,m表示检测到相同字母的位置,下一次循环则从m+1检测

#include <cstdio>
#include <cstring>
#define maxn 100000

int main()
{
    char s[maxn],t[maxn];
    while(scanf("%s%s",s,t)!=EOF)
    {
        int cnt=0;int m=0;
        for(int i=0; i<strlen(s); i++)
        {
            for(int j=m; j<strlen(t); j++)
            {
                if(s[i]==t[j])
                {
                    cnt++;
                    m=j+1;
                    break;
                }
               t[j]=' ';
            }
        }
        if(cnt==strlen(s))
            printf("Yes\n");
        else
            printf("No\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值