A triangle is a Heron’s triangle if it satisfies that the side lengths of it are consecutive integers t−1, t, t+ 1 and thatits area is an integer. Now, for given n you need to find a Heron’s triangle associated with the smallest t bigger
than or equal to n.
Input
The input contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T ≤ 30000) followedby T lines. Each line contains an integer N (1 ≤ N ≤ 10^30).
Output
For each test case, output the smallest t in a line. If the Heron’s triangle required does not exist, output -1.
Sample Input
4
1
2
3
4
Sample Output
4
4
4
4
题意
已知三角形三边为t-1,t,t+1。给你一个n,找到这样一个大于n的并且尽可能小的t,使得三角形的面积为整数。
思路
运用海伦公式。
S = p ( p − a ) ( p − b ) ( p − c ) \sqrt{p(p-a)(p-b)(p-c)} p(p−a)(p−b)(p−c) p = a + b + c 2 \frac{a+b+c}{2} 2a+b+c
暴力打表找规律,再用java的BigInteger类打表遍历。
代码
import java.io.*;
import java.util.*;
import java.math.*;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
int i;
BigInteger s[] = new BigInteger[110];
s[0] = new BigInteger("4");
s[1] = new BigInteger("14");
for(i = 2; i < 110; i++) {
s[i] = s[i-1].multiply(BigInteger.valueOf(4)).subtract(s[i-2]);
}
int j,T;
T = cin.nextInt();
for(j = 0; j < T; j++)
{
BigInteger n = cin.nextBigInteger();
for(i = 0; i < 110; i++)
{
if(s[i].compareTo(n) >= 0)
{
System.out.println(s[i]);
break;
}
}
if(i == 110)
System.out.println(-1);
}
}
}