F - Heron and His Triangle HDU - 6222

A triangle is a Heron’s triangle if it satisfies that the side lengths of it are consecutive integers t-1, t, t+ 1 and thatits area is an integer. Now, for given n you need to find a Heron’s triangle associated with the smallest t bigger
than or equal to n.
Input
The input contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T ≤ 30000) followedby T lines. Each line contains an integer N (1 ≤ N ≤ 10^30).
Output
For each test case, output the smallest t in a line. If the Heron’s triangle required does not exist, output -1.
Sample Input
4
1
2
3
4
Sample Output
4
4
4
4

  • 题意:给你一个n,在t>=n的范围内求一个数t.使得t-1,t,t+1所组成的三角形面接为整数.

  • 解题思路:打一个表,发现递增的很快,并且递归方程为s[n]=4*s[n-1]-s[n-2].由于数据太大,因此用java大数表示.

import java.math.BigInteger;
import java.math.*;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        BigInteger []m=new BigInteger[60];
        m[0]=BigInteger.valueOf(2);
        m[1]=BigInteger.valueOf(4);
        for(int i=2;i<60;i++) {
        	m[i]=m[i-1].multiply(BigInteger.valueOf(4)).subtract(m[i-2]);
        }
        int t;t=input.nextInt();
        for(int j=0;j<t;j++){
        	BigInteger h;
        	h=input.nextBigInteger();
        	for(int i=1;i<60;i++) {
        		if(m[i].compareTo(h)>=0) {System.out.println(m[i]);break;}
        	}
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值