1076 Forwards on Weibo (30 point(s))

1076 Forwards on Weibo (30 point(s))

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i]users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

思路:BFS

实际上,微博关注关系图可以想象成一棵树,结点为用户,直接儿子为关注者,但是这棵树有的儿子结点在树中多次出现。本题的求解就是计算这棵树中层次小于6的不重复结点个数,容易想到用BFS(广度优先搜索)。注意到结点至多1e3个且编号为1~N,因此采用哈希思想,数组mark[]标记这些结点是否已经被计入、数组level[]记录结点所在(最低)层次。

BFS中,构建一个queue<int> q,首先把目标用户k入队。对于每个队首用户,先出队列,查找它的k的关注者,如果该关注者尚未被标记且该用户的传播层次还小于L(只有这样,该关注者传播层次才小于等于L),则cnt自加1,并标记,更新层次,将该用户入队。直到该队列为空。

注意点:

1. 输入给出的关注图,建立的vector<int> followers[N]是被关注者数组。

2. BFS流程和哈希思想。

3. BFS可用结构体Node来组合标记。

大神深度分析:https://blog.csdn.net/richenyunqi/article/details/80138420

#include<iostream>
#include<vector>
#include<queue>
#define MAX 0x3f3f3f3f
using namespace std;
const int N = 1e3+7;
vector<int> followers[N];
int bfs(int k,int L){
	int cnt = 0;
	queue<int> q;
	while(!q.empty()) q.pop();
	q.push(k);
	bool mark[N]={false};
	int level[N];
	for(int i=0;i<N;i++) level[i]=MAX;
	mark[k]=true;
	level[k]=0;
	while(!q.empty()){
		int v = q.front();
		q.pop();
		for(int i=0;i<followers[v].size();i++){
			int u = followers[v][i];
			if(mark[u]==false&&level[v]+1<=L){
				cnt++;
				mark[u]=true;
				level[u]=level[v]+1;
				q.push(u);
			}
		}
	}
	return cnt;
}
int main(void)
{
	int N,L;
	cin>>N>>L;
	int n,a,k;
	for(int i=1;i<=N;i++){
		cin>>n;
		for(int j=0;j<n;j++){
			cin>>a;
			followers[a].push_back(i);	
		}
	}
	cin>>k;
	for(int i=0;i<k;i++){
		cin>>n;
		cout<<bfs(n,L)<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值