1085 Perfect Sequence (25 point(s))

1085 Perfect Sequence (25 point(s))

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N(≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are Npositive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思路见代码,很容易懂!思路参考大神:https://blog.csdn.net/richenyunqi/article/details/79512471

复杂度是o(n^2):case#4出现TLE(22分)

#include<iostream>
#define ll long long
using namespace std;
const int N  = 1e5+7;
int a[N];
int main(void){
	int n;ll p;
	cin>>n>>p;
	for(int i=0;i<n;i++) cin>>a[i];
	int cnt = 0;int ans = 0;
	for(int i=0;i<n;i++){
		ll m = a[i];cnt=0;
		for(int j=0;j<n;j++){
			ll M = a[j];
			if(M<=p*m&&M>=m) cnt++;
		}
		if(cnt>ans) ans=cnt;
	}
	cout<<ans<<endl;
	return 0;
}

看起来复杂度没有变,需要在之后的序列中去查找第一个大于其p倍的数,实际上STL使用二分查找解决,降低复杂度。

#include<iostream>
#include<algorithm> 
#define ll long long
using namespace std;
const int N  = 1e5+7;
ll a[N];
int main(void){
	int n;ll p;
	cin>>n>>p;
	for(int i=0;i<n;i++) cin>>a[i];
	sort(a,a+n);
	int maxLen = 0;
	for(int i=0;i<n;i++){
		int len = upper_bound(a+i+1,a+n,a[i]*p)-a-i;//二分查找降低复杂度 
		maxLen = max(len,maxLen);
	}
	cout<<maxLen<<endl;
	return 0; 
}

双指针(非常巧妙,仔细想也容易想到):

#include<bits/stdc++.h>
using namespace std;
int main(){
    int N;
    long long p;
    scanf("%d%lld",&N,&p);
    long long a[N];
    for(int i=0;i<N;++i)
        scanf("%lld",&a[i]);
    sort(a,a+N);
    int i=0,j=0,maxLength=-1;
    while(j!=N){
        while(j!=N&&a[i]*p>=a[j])
            ++j;
        maxLength=max(maxLength,j-i);
        ++i;
    }
    printf("%d",maxLength);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值