1085 Perfect Sequence (25 分)

1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
#Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

code

/*
提交:1次 WA 理解错题意:求序列的最大数量而不是最大值
提交:2次 the last test WA lower_bound错误,改用upper_bound
提交:3次 the last test WA upper_bound()函数内查找的数值要long long型

*/
#include <stdio.h>
#include <algorithm>
using namespace std;

typedef long long ll;
const int maxn = 100005;
int a[maxn];

int main()
{
    int n, p;
    int maxn = 0;
    scanf("%d%d",&n,&p);
    for(int i = 0; i < n; ++i){
        scanf("%d",&a[i]);
    }
    sort(a, a + n);
    for(int i = 0; i < n; ++i){
        //long long num = a[i] * p;
        int pos = upper_bound(a + i + 1, a + n, (long long)a[i]*p) - a;
        maxn = max(maxn, pos - i);
    }
    printf("%d",maxn);
    return 0;
}

note1

  • 下面这种写法使最后一个test错误
long long num = a[i] * p;
int pos = upper_bound(a + i + 1, a + n, num) - a;
  • 必须下面这样写
int pos = upper_bound(a + i + 1, a + n, (long long)a[i]*p) - a;
  • 猜测是因为该函数自动将num作为整型处理,即使它是一个长整型,因此需要进行强制转换;或者将数组a和参数p均定义为long long

note2

  • 这道题用二分查找,而lower_bound和upper_bound自带的利用二分查找的库函数
  • 关于lower_bound()和upper_bound()
  • 由于前者是查找第一个大于或等于num的数,而num的值在序列中可能不止一个,如果使用lower_bound可能会使最终答案缩小
  • upper_bound()查找第一个大于num的数,这样的话只需将找到的数组长度-1即为答案
  • 补充:https://blog.csdn.net/qq_40160605/article/details/80150252

参考

其他(手写二分)*

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值