1108 Finding Average (20 point(s))

1108 Finding Average (20 point(s))

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then Nnumbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

中等模拟题。

模拟题心得:判断时,要根据限制条件选择给出合法条件还是不合法条件。有时候,难以想到所有完备的不合法条件。

巨坑:当合法数字是1的时候,number(s)不应该取复数! 

#include<iostream>
#include<cstring>
using namespace std;
bool isLegal(string s,double &n){
	n=0;
	bool isNeg = false;
	if(s[0]=='-'){
		isNeg = true;
		s.erase(s.begin());
	}
	bool hasPoint = false;
	int in = 0;
	double p=0;
	int cnt=0;
	for(int i=0;i<s.length();i++){
		if(s[i]>='0'&&s[i]<='9'){
			if(!hasPoint) in=10*in+(s[i]-'0');
			else if(hasPoint&&cnt<2){
				cnt++;
				if(cnt==1) p = 0.1*(s[i]-'0');
				else if(cnt==2) p+=0.01*(s[i]-'0');
			}
			else return false;
		}
		else if(in!=0&&s[i]=='.'&&!hasPoint) hasPoint = true;
		else return false;
	}
	if(isNeg) n = -p-in;
	else n = p+in;
	if(n<=1000.0&&n>=-1000.0) return true;
	else return false;
}
int main(void){
	int N;cin>>N;
	int cnt = 0;double sum = 0;
	string s;double x;
	for(int i=0;i<N;i++){
		cin>>s;
		if(isLegal(s,x)){
			cnt++;
			sum+=x;
		}
		else{
			cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
		}
	}
	if(cnt==1) cout<<"The average of "<<cnt<<" number is ";
	else cout<<"The average of "<<cnt<<" numbers is ";
	
	if(cnt==0) cout<<"Undefined"<<endl;
	else {
		printf("%.2f\n",sum/cnt);
	}
} 

 

内容概要:本文详细探讨了基于樽海鞘算法(SSA)优化的极限学习机(ELM)在回归预测任务中的应用,并与传统的BP神经网络、广义回归神经网络(GRNN)以及未优化的ELM进行了性能对比。首先介绍了ELM的基本原理,即通过随机生成输入层与隐藏层之间的连接权重及阈值,仅需计算输出权重即可快速完成训练。接着阐述了SSA的工作机制,利用樽海鞘群体觅食行为优化ELM的输入权重和隐藏层阈值,从而提高模型性能。随后分别给出了BP、GRNN、ELM和SSA-ELM的具体实现代码,并通过波士顿房价数据集和其他工业数据集验证了各模型的表现。结果显示,SSA-ELM在预测精度方面显著优于其他三种方法,尽管其训练时间较长,但在实际应用中仍具有明显优势。 适合人群:对机器学习尤其是回归预测感兴趣的科研人员和技术开发者,特别是那些希望深入了解ELM及其优化方法的人。 使用场景及目标:适用于需要高效、高精度回归预测的应用场景,如金融建模、工业数据分析等。主要目标是提供一种更为有效的回归预测解决方案,尤其是在处理大规模数据集时能够保持较高的预测精度。 其他说明:文中提供了详细的代码示例和性能对比图表,帮助读者更好地理解和复现实验结果。同时提醒使用者注意SSA参数的选择对模型性能的影响,建议进行参数敏感性分析以获得最佳效果。
### 解决方案 如果遇到 `NetworkManager` 缺少 Wi-Fi 支持的问题,可以通过安装相应的插件包并重新启动服务来解决问题。 #### 安装 NetworkManager-WiFi 插件 在联网的情况下,可以使用以下命令直接安装 `NetworkManager-wifi` 插件包[^2]: ```bash yum -y install NetworkManager-wifi ``` 此操作会下载并安装必要的组件以启用 Wi-Fi 功能。确保当前环境具有有效的互联网连接以便完成软件包的获取和安装过程。 #### 重启 NetworkManager 服务 一旦插件成功安装,则需通过重启 `NetworkManager` 服务使更改生效[^1]: ```bash systemctl restart NetworkManager.service ``` 上述步骤能够确保新加入的功能模块被正确加载到系统的服务框架之中。 #### 检查网络服务状态 为了验证网络管理器是否正常运作以及确认是否有任何潜在错误影响其性能,可利用如下指令查询服务的具体状况[^4]: ```bash systemctl status NetworkManager ``` 这条命令返回的信息有助于判断先前所做的调整是否达到了预期效果,并能提供进一步调试的方向线索假如存在问题的话。 #### 手动配置网卡参数 (如有必要) 对于某些特定场景下可能还需要手动编辑网卡的相关设置文件比如 ens192 的 nmconnection 文件样例展示了一个完整的 Ethernet 连接定义其中包括 IP 地址分配方式(DNS 设置)[^5]: ```ini [connection] id=ens192 uuid=84405101-5169-37ee-a911-185d8a0828b3 type=ethernet autoconnect-priority=-999 interface-name=ens192 timestamp=1732156159 [ethernet] [ipv4] address1=192.168.21.189/20,192.168.21.1 DNS=192.168.21.2 method=manual [ipv6] addr-gen-mode=eui64 method=auto [proxy] ``` 尽管这是针对有线网络的一个例子,但是它展示了如何精确设定各个层面从而实现稳定可靠的通信链路建立;类似的方法也可以应用于无线适配器上依据实际需求做出相应修改即可满足复杂多变的实际应用场合的要求。 --- ### 注意事项 多数现代 Linux 发行版均采用 `NetworkManager` 工具作为默认手段来进行全局范围内的网络资源调度管理工作[^3] 。因此,在实施以上措施之前最好先了解清楚目标平台所依赖的基础架构特性以免造成不必要的干扰或者破坏原有功能布局结构稳定性下降等问题发生几率增加等情况出现。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值