1108 Finding Average (20 point(s))

1108 Finding Average (20 point(s))

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then Nnumbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

中等模拟题。

模拟题心得:判断时,要根据限制条件选择给出合法条件还是不合法条件。有时候,难以想到所有完备的不合法条件。

巨坑:当合法数字是1的时候,number(s)不应该取复数! 

#include<iostream>
#include<cstring>
using namespace std;
bool isLegal(string s,double &n){
	n=0;
	bool isNeg = false;
	if(s[0]=='-'){
		isNeg = true;
		s.erase(s.begin());
	}
	bool hasPoint = false;
	int in = 0;
	double p=0;
	int cnt=0;
	for(int i=0;i<s.length();i++){
		if(s[i]>='0'&&s[i]<='9'){
			if(!hasPoint) in=10*in+(s[i]-'0');
			else if(hasPoint&&cnt<2){
				cnt++;
				if(cnt==1) p = 0.1*(s[i]-'0');
				else if(cnt==2) p+=0.01*(s[i]-'0');
			}
			else return false;
		}
		else if(in!=0&&s[i]=='.'&&!hasPoint) hasPoint = true;
		else return false;
	}
	if(isNeg) n = -p-in;
	else n = p+in;
	if(n<=1000.0&&n>=-1000.0) return true;
	else return false;
}
int main(void){
	int N;cin>>N;
	int cnt = 0;double sum = 0;
	string s;double x;
	for(int i=0;i<N;i++){
		cin>>s;
		if(isLegal(s,x)){
			cnt++;
			sum+=x;
		}
		else{
			cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
		}
	}
	if(cnt==1) cout<<"The average of "<<cnt<<" number is ";
	else cout<<"The average of "<<cnt<<" numbers is ";
	
	if(cnt==0) cout<<"Undefined"<<endl;
	else {
		printf("%.2f\n",sum/cnt);
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值