1106 Lowest Price in Supply Chain (25 point(s))

1106 Lowest Price in Supply Chain (25 point(s))

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

问题的本质:求树的叶子节点的最低层次及其个数。

思路:

1. 存储树的结构(注意到这是有向树)。注意根据输入标记叶子结点。

2. 采用BFS方式遍历整棵树,求出每一个结点的层次。

3. 根据1的标记,求出叶子节点的最低层次,并累计个数。

同时参考1079 Total Sales of Supply Chain1090 Highest Price in Supply Chain

也可以用DFS求解。

参考链接:https://blog.csdn.net/richenyunqi/article/details/80152791

#include<iostream>
#include<vector>
#include<cstring>
#include<queue>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX = 1e5+7;
vector<int> graph[MAX];
int level[MAX];
bool isRetailer[MAX]={false};
int minLevel = INF;
void bfs(int root){//BFS求出每一个结点的层次,并求出叶子节点的最低层次 
	queue<int> q;
	q.push(root);
	level[root]=0;
	while(!q.empty()){
		int top = q.front();
		q.pop();
		if(isRetailer[top]){//如果这是一个叶子节点 
			minLevel=min(minLevel,level[top]);
		}
		for(int i=0;i<graph[top].size();i++){//否则遍历这些节点,更新它们的层次,并加入队列 
			int cur = graph[top][i];
			level[cur]=level[top]+1;
			q.push(cur);
		}
	}
}
int main(void){
	int N,K,a;double p,r;
	cin>>N>>p>>r;
	for(int i=0;i<N;i++){
		cin>>K;
		if(K==0) isRetailer[i]=true;
		while(K--){
			cin>>a;
			graph[i].push_back(a);
		}
	}
	int root = 0;
	bfs(root);
	int cnt =0;
	for(int i=0;i<N;i++){
		if(isRetailer[i]&&level[i]==minLevel) cnt++;
	}
	printf("%.4f %d",p*pow((1+0.01*r),minLevel),cnt);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值