1136 A Delayed Palindrome (20 point(s))

1136 A Delayed Palindrome (20 point(s))

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

回文串判断、基于字符串的加法。

 注意点:

1. 在每一次迭代之前先判断是不是回文串;

2. 字符串的加法注意考虑进位,注意最终加法结果翻转。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
bool isPal(string s){
	for(int i=0;i<s.length()/2;i++){
		if(s[i]!=s[s.length()-1-i]) return false;
	}
	return true;
}
string add(string a){
	string b = a;
	reverse(a.begin(),a.end());
	int carry=0;
	string ans="";
	for(int i=0;i<a.length();i++){
		int c = a[i]-'0'+b[i]-'0'+carry;
		carry = c/10;
		ans+=char(c%10 +'0');
	}
	if(carry!=0) ans+=char(carry+'0');
	reverse(ans.begin(),ans.end());
	cout<<b<<" + "<<a<<" = "<<ans<<endl;
	return ans;
}
int main(void){
	string s;cin>>s;
	bool flag = false;
	for(int i=0;i<10;i++){
		if(isPal(s)){//先判断是否回文 
			flag = true;
			cout<<s<<" is a palindromic number."<<endl;
			break;
		}
		s = add(s);
	}
	if(!flag) cout<<"Not found in 10 iterations."<<endl;
	return 0;
}

 

ScheduledExecutorService是Java中的一个接口,它是ExecutorService的子接口之一,用于在给定的延迟时间之后或定期执行任务。它提供了一种简单而方便的方式来调度任务。 使用ScheduledExecutorService,你可以执行两种类型的任务:延迟任务和周期性任务。延迟任务是指在指定的延迟时间之后执行一次的任务,而周期性任务是指在指定的延迟时间之后开始执行,并且在每个执行完成后按照给定的间隔时间重复执行。 ScheduledExecutorService接口提供了几种方法来执行这些任务,例如schedule()用于执行延迟任务,scheduleAtFixedRate()和scheduleWithFixedDelay()用于执行周期性任务。 下面是一个简单的示例代码,演示了如何使用ScheduledExecutorService执行延迟任务: ```java import java.util.concurrent.Executors; import java.util.concurrent.ScheduledExecutorService; import java.util.concurrent.TimeUnit; public class ScheduledExecutorServiceExample { public static void main(String[] args) { ScheduledExecutorService executor = Executors.newScheduledThreadPool(1); Runnable task = () -> { System.out.println("Delayed task executed."); }; int delay = 5; // 延迟时间为5秒 executor.schedule(task, delay, TimeUnit.SECONDS); executor.shutdown(); } } ``` 这个例子中,我们创建了一个ScheduledExecutorService实例,并使用newScheduledThreadPool()方法创建一个线程池。然后,我们定义了一个Runnable任务,该任务将在指定的延迟时间之后执行一次。最后,我们使用schedule()方法将任务提交给ScheduledExecutorService,并指定延迟时间和时间单位。 希望这个例子能帮助你理解ScheduledExecutorService的基本用法。如果你还有其他问题,请随时问我!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值