1143 Lowest Common Ancestor (30 point(s))
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A.
if the LCA is found and A
is the key. But if A
is one of U and V, print X is an ancestor of Y.
where X
is A
and Y
is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found.
or ERROR: V is not found.
or ERROR: U and V are not found.
.
Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
类似1151。根据BST前序重建树、
只需要注意:
1. BST的中序遍历是非递减的。
2. 结点的静态存储是基于前序或者后序的。
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int M,N;
const int MAX = 1e4+7;
struct Node{
int data;int level;int father;
Node(int d=0,int l=0,int f=-1):data(d),level(l),father(f){}
};
Node pre[MAX];
int in[MAX];
void createTree(int root,int left,int right,int father,int level){
if(left>right) return;
pre[root] = Node(pre[root].data,level,father);
int index = left;
while(pre[root].data!=in[index]) index++;
createTree(root+1,left,index-1,root,level+1);
createTree(root+1+index-left,index+1,right,root,level+1);
}
int main(void){
cin>>M>>N;
for(int i=0;i<N;i++) cin>>in[i];
for(int i=0;i<N;i++) cin>>pre[i].data;
createTree(0,0,N-1,-1,0);
int a,b;
for(int i=0;i<M;i++){
cin>>a>>b;
int ai=N;int bi=N;
for(int i=0;i<N;i++){
if(a==pre[i].data) ai = i;
if(b==pre[i].data) bi = i;
}
if(ai==N&&bi==N) printf("ERROR: %d and %d are not found.\n",a,b);
else if(ai==N&&bi!=N) printf("ERROR: %d is not found.\n",a);
else if(ai!=N&&bi==N) printf("ERROR: %d is not found.\n",b);
else{
bool deeper = true;//Node a is deeper;
if(pre[ai].level<pre[bi].level){
deeper = false;
swap(ai,bi);
}
while(pre[ai].level!=pre[bi].level) ai = pre[ai].father;
if(ai==bi){
printf("%d is an ancestor of %d.\n",(deeper?b:a),(deeper?a:b));
}
else{
while(ai!=bi){
ai = pre[ai].father;
bi = pre[bi].father;
}
printf("LCA of %d and %d is %d.\n",a,b,pre[ai].data);
}
}
}
return 0;
}