1135 Is It A Red-Black Tree (30 point(s))

1135 Is It A Red-Black Tree (30 point(s))

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

 红黑树的判断。

二叉搜索树的建立、计算从任意一个结点到叶子的黑色结点个数、动态结点二叉树

#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#include<set>
using namespace std;
int K,N;bool isOK;
struct Node{
	int data;Node* left;Node* right;
	Node(int d):data(d),left(nullptr),right(nullptr){}
};
void insert(Node* &root,int key){
	if(root==nullptr){
		root = new Node(key);
		return;
	}
	if(abs(key)<abs(root->data)) insert(root->left,key);
	else insert(root->right,key);
}
set<int> s;
void getBlack(Node* root,int cnt){
	if(root==nullptr){
		s.insert(cnt);
		return;
	}
	if(root->data>0) cnt++;
	getBlack(root->left,cnt);
	getBlack(root->right,cnt);
}
void dfs(Node* root){
	if(root==nullptr) return;
	if(root->data<0){
		if(root->left!=nullptr&&root->left->data<0) {isOK = false;return;}
		if(root->right!=nullptr&&root->right->data<0) {isOK = false;return;}
	}
	s.clear();
	getBlack(root,0);
	if(s.size()!=1) {isOK = false;return;}
	if(root->left!=nullptr) dfs(root->left);
	if(root->right!=nullptr) dfs(root->right);
}
int main(void){
	cin>>K;int a;
	while(K--){
		cin>>N;
		Node* root = nullptr;
		isOK = true;
		for(int i=0;i<N;i++){
			cin>>a;
			insert(root,a);
		}
		if(root!=nullptr&&root->data<0) isOK=false;
		if(isOK){
			dfs(root);
		}
		if(isOK) puts("Yes");
		else puts("No");
	}
	return 0;
}

大神代码:

参考链接:https://blog.csdn.net/richenyunqi/article/details/82292391 

#include<bits/stdc++.h>
using namespace std;
struct Node{//二叉树结点定义
    int data,leftNum,rightNum;
    Node*left,*right;
    Node(int d):data(d),left(nullptr),right(nullptr),leftNum(0),rightNum(0){}
};
void insertTree(Node*&root,int data){//二叉查找树的插入节点算法
    if(root==nullptr){
        root=new Node(data);
        return;
    }
    if(abs(root->data)>abs(data))
        insertTree(root->left,data);
    else
        insertTree(root->right,data);
}
int getBlackNum(Node*root){//计算左右子树中黑色结点个数
    if(root==nullptr)
        return 1;
    root->leftNum=getBlackNum(root->left);//计算左子树中黑色结点个数
    root->rightNum=getBlackNum(root->right);//计算右子树中黑色结点个数
    return root->data<0?root->leftNum:root->leftNum+1;
}
bool judge(Node*root){//判断给定的树是否满足4、5条性质
    if(root==nullptr)
        return true;
    bool leftBlack=root->left==nullptr||root->left->data>0;
    bool rightBlack=root->right==nullptr||root->right->data>0;
    bool f1=root->data>0?true:leftBlack&&rightBlack;//是否满足性质4
    bool f2=root->leftNum==root->rightNum;//是否满足性质5
    return f1&&f2&&judge(root->left)&&judge(root->right);//递归判断左右子树
}
int main(){
    int K,N,a;
    scanf("%d",&K);
    while(K--){
        scanf("%d",&N);
        Node*root=nullptr;
        for(int i=0;i<N;++i){
            scanf("%d",&a);
            insertTree(root,a);
        }
        getBlackNum(root);
        bool isRBT=root->data>0&&judge(root);
        printf("%s\n",isRBT?"Yes":"No");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值