百练 1745: Divisibility

百练 1745: Divisibility

总时间限制:1000ms 内存限制:65536kB
原题OJ链接

描述

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.

输入

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it’s absolute value.

输出

Write to the output file the word “Divisible” if given sequence of integers is divisible by K or “Not divisible” if it is not.

样例输入

4 7
17 5 -21 15

样例输出

Divisible

解题思路

题目大意:给出N和K,然后给出N个整数(不论正负),问在这N个数中,每两个数之间(即N - 1个位置)添加加号或者减号,然后运算的值对K取余,如果余数等于0输出Divisible,否则输出Not divisible。

例如本题样例:
17 mod 7 = 3

(3+5) mod 7 = 1
(3-5) mod 7 = 5

(1+21) mod 7 = 1
(1-21) mod 7 = 1
(5+21) mod 7 = 5
(5-21) mod 7 = 5

(1+15) mod 7 = 2
(1-15) mod 7 = 0
(5+15) mod 7 =6
(5-15) mod 7 = 4

同理可以找到规律,定义dp[i][j]为前 i 个数进来余数等于 j 是不是成立,1为成立,0为不成立
那么如果dp[N][0]为1那么即可以组成一个数对K取余为0.
初始化dp为0

参考这位大神的分析: http://blog.csdn.net/wangjian8006/article/details/10170671

源代码

#include<iostream>
#include<cstring>
using namespace std;
int N,K;
int dp[10005][105];
int seq[10005];
int myMod(int n, int k){
    //对于负数,原先用%符号结果还是负数,这个函数的功能为mod,即结果都为正数
    n=n%k;
    while(n<0) n=n+k;
    return n;
}
int main(){
    cin>>N>>K;
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=N;i++){
        cin>>seq[i];
    }
    dp[1][myMod(seq[1],K)]=1;
    for(int i=2;i<=N;i++){
        for(int j=0;j<K;j++){
            if(dp[i-1][j]){
                dp[i][myMod(j+seq[i],K)]=1;
                dp[i][myMod(j-seq[i],K)]=1;
            }
        }
    }
    if(dp[N][0]) cout<<"Divisible"<<endl;
    else cout<<"Not divisible"<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值