百练 2075: Tangled in Cables

百练 2075: Tangled in Cables

原题OJ链接

描述

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

输入

Only one town will be given in an input.

The first line gives the length of cable on the spool as a real number.
The second line contains the number of houses, N
The next N lines give the name of each house’s owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
Next line: M, number of paths between houses
next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

输出

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

样例输入

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

样例输出

Need 10.2 miles of cable

解题思路

最小生成树。
在这里,用到了STL中的map,在这里map<string, int> myMap; map中的key值为string类型的 < house name >,value值为int类型的,即把 house name 映射到节点 i 。然后用prim()算法来求最小生成树。

源代码

#include<iostream>
#include<map>
#define MAX_V 505
using namespace std;
map<string, int> myMap;
double cost[MAX_V][MAX_V];
double mincost[MAX_V];
bool used[MAX_V];
int N,M;
const double INF=9999999999.0;
double prim(){
    for(int i=0;i<N;i++){
        mincost[i]=INF;
        used[i]=false;
    }
    mincost[0]=0.0;
    double res=0.0;
    while(true){
        int v=-1;
        for(int u=0;u<N;u++){
            if(!used[u] && (v==-1 || mincost[u]<mincost[v]))
                v=u;
        }

        if(v==-1) break;
        used[v]=true;
        res+=mincost[v];
        for(int u=0;u<N;u++){
            mincost[u]=min(mincost[u],cost[v][u]);
        }
    }
    return res;
}

int main(){
    double cables;
    double dis;
    string str,str1,str2;
    cin>>cables>>N;
    for(int i=0;i<N;i++){
        cin>>str;
        myMap[str]=i;
    }
    cin>>M;
    for(int i=0;i<N;i++){
        for(int j=0;j<N;j++){
            cost[i][j]=INF;
        }
    }
    for(int i=0;i<M;i++){
        cin>>str1>>str2>>dis;
        cost[myMap[str1]][myMap[str2]]=dis;
        cost[myMap[str2]][myMap[str1]]=dis;
    }

    double sum=prim();
    if(sum<=cables) cout<<"Need "<<sum<<" miles of cable"<<endl;
    else cout<<"Not enough cable"<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值