九度 题目1460:Oil Deposit

1 篇文章 0 订阅

九度 题目1460:Oil Deposit

原题OJ链接:http://ac.jobdu.com/problem.php?pid=1460

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’ , representing the absence of oil, or ‘@’, representing an oil pocket.

输出:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入:

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

样例输出:

0
1
2
2

解题思路:

DFS
题目大意:在给定的n*m图中,确定有几个@的块。块符合以下条件,其中的任意对@均互相直接或间接连通,两个@直接相邻或者对角相邻即被视为连通。
每次进行DFS搜索时,若找到一块@与当前@相连,则把找到的@所在位置设为‘*’,遍历整个图,遇到@就进行DFS,同时块数ans++。

源代码:

#include<iostream>
using namespace std;
int dx[8]={-1,-1,-1,0, 0,1,1, 1};
int dy[8]={ 0, 1,-1,1,-1,0,1,-1};
char maze[105][105];
bool mark[105][105];
int n,m;
void DFS(int x,int y){
    for(int i=0;i<8;i++){
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(nx>=0 && nx<m && ny>=0 && ny<n && maze[nx][ny]=='@'){
            maze[nx][ny]='*';
            DFS(nx,ny);
        }
    }
    return ;
}

int main(){
    while(cin>>m>>n && n!=0 && m!=0){
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                cin>>maze[i][j];
            }
        }
        int ans=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                if(maze[i][j]=='@'){
                    DFS(i,j);
                    ans++;
                }
            }
        }
        cout<<ans<<endl; 
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值