hdu 4939 Stupid Tower Defense() dp

Stupid Tower Defense

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1294    Accepted Submission(s): 383


Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.

The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower. 

The red tower damage on the enemy x points per second when he passes through the tower.

The green tower damage on the enemy y points per second after he passes through the tower.

The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)

Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.

FSF now wants to know the maximum damage the enemy can get.
 

Input
There are multiply test cases.

The first line contains an integer T (T<=100), indicates the number of cases. 

Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
 

Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
 

Sample Input
  
  
1 2 4 3 2 1
 

Sample Output
  
  
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
 

Author
UESTC
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4955  4954  4953  4952  4951 
 



题目大意:
有在一条长度为 n单位的直线上,直线上会通过怪物,这些怪物拥有一个通过单位长度的时间 t
可以设置红蓝绿三种塔来设防,每种塔占用一个单位
其中 红塔是当怪物处于 当前单位时会产生攻击输出,伤害为每秒 x
绿塔是当怪物 通过以后每秒都会产生伤害,为 y
蓝塔是怪物 通过后,怪物通过一个单位长度的时间增加 z

提交情况:WA WA WA WA WA WA WA....AC= =

反省&总结:
(1)首先dp推导递推式的姿势就不是很高,亟需提升。

(2)接着下标处理能力较差,公式错了检查的时候也没有检查出来

(3)发现,dp只要递推公式正确,加上下标处理正确,一般很容易ac。wa一般就是wa在
dp过程中,会漏掉一些dp没有参与到递推过程中或者是加入了不该加入的dp,
往后要练一下脑跑dp和手推dp前几项后几项的能力。


下面是ac代码:
主要就是下面用注释标注出来的地方,
那里不应是线性增长的,应该是线性增长的叠加,也就是等差数列
竟然看了很久才看出来- -晕
也和对数学不是很敏感有关

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <numeric>
#include <functional>
#define maxn 1600
#define maxe 10005

using namespace std;
typedef long long ll;
const double EPS=1e-10;
ll dp[maxn][maxn];

int main()
{
    int t;
    int countt=0;
    scanf("%d",&t);
    while(t--){
        countt+=1;
        ll n,x,y,z,t;
        scanf("%I64d %I64d %I64d %I64d %I64d",&n,&x,&y,&z,&t);
        memset(dp,0,sizeof(dp));
        ll maxdp=0;
        maxdp=n*x*t<(n-1)*x*(t+z)?(n-1)*x*(t+z):n*x*t;
        //全是红塔和第一个放蓝塔的比较
        maxdp=maxdp<(n-1)*t*(y+x)?(n-1)*t*(y+x):maxdp;
        //第一个放蓝塔和上一行结果的比较
        for(ll i=1;i<n;i+=1){
            //dp[i+1][0]=i*y*t;//前i+1个位置放0个蓝塔
            dp[i+1][0]=dp[i][0]+t*i*y;
            maxdp=maxdp<dp[i+1][0]+(n-i-1)*t*((i+1)*y+x)?dp[i+1][0]+(n-i-1)*t*((i+1)*y+x):maxdp;
            for(ll j=0;j<=i;j+=1){
                dp[i+1][j+1]=max(dp[i][j]+(i-j)*y*(t+j*z),dp[i][j+1]+max(0LL,(i-j-1))*y*(t+(j+1)*z));
                ll tmp=dp[i+1][j+1]+(n-i-1)*(x+(i-j)*y)*(t+(j+1)*z);
                maxdp=maxdp<tmp?tmp:maxdp;
            }
        }

        printf("Case #%d: %I64d\n",countt,maxdp);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值