Junk-Mail Filter

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 201 Accepted Submission(s): 70

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0
 

Sample Output
Case #1: 3
Case #2: 2
 


Source


使用虚拟节点删除

1-n   n-n+n为须根

例如:parent[1]=1+n;

      删除1,令parent[1]=n+n+1;

       
#include<iostream>
#include<algorithm>
using namespace std;
int N,M;
int parent[3000000];
int id[100003];
void init(int n,int m)
{
int i=0;
for(i=0;i<n;i++)
{
  parent[i]=i+n;

}
for(i=n;i<2*n+m;i++)
{
    parent[i]=i;

}




}
int find(int a)
{
    int temp=a;
while(temp!=parent[temp])
{
   temp=parent[temp];
}
return temp;


}
void combine(int a,int b)
{
   int p1=find(a);
   int p2=find(b);
   if(p1<p2)
   {
      parent[p1]=p2;
   
   }
   else{
      parent[p2]=p1;
   }


}




int main()
{
//freopen("in.txt","r",stdin);
  int icase=0;
  while(scanf("%d%d",&N,&M)!=EOF)
  {
 memset(id,0,sizeof(id));
 if(N==0&&M==0)
 {
   break;
 }
 int k=2*N;
      init(N,M);
 char ch;
 
 while(M--)
 {
 cin>>ch;
    if(ch=='M')
{
    int a,b;
    cin>>a>>b;
    combine(a,b);
 
}
     else{


          int c;
      cin>>c;
      parent[c]=k++;
 }
 }
 
 for(int i=0;i<N;i++)
 {
 id[i]=find(i);
 }
 sort(id,id+N);
 int re=1;
 for(int j=0;j<N-1;j++)
 {
    if(id[j]!=id[j+1])
{
   re++;
 
}
 }
 cout<<"Case #"<<++icase<<": "<<re<<endl;
    
  
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值