【HDU2473】Junk-Mail Filter

                                Junk-Mail Filter

                Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                     Total Submission(s): 11601    Accepted Submission(s): 3641

 

Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

 

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

 

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

 

Sample Input

 

5 6

M 0 1

M 1 2

M 1 3

S 1

M 1 2

S 3

3 1

M 1 2

0 0

Sample Output

 

Case #1:

3 Case #2: 2

 

解析:

       并查集的经典题型——删点操作。

       具体做法就时最初点i的 father 设为i+n,合并还是照常合并,删点就是再新建一个点,将删的那个点的 father 赋为新建的那个点。比如说 1 2 3 最初的 father 分别为 4 5 6 ,如果合并1 2 3 后共同的 father 为4,这时要删1就将1的 father 设为7,其他2 3 的 father 仍然为4。

 

代码:

#include <bits/stdc++.h>
using namespace std;

const int Max=1200005;
int t,n,m,x,y,fax,fay,ans,id;
int father[Max],vis[Max];
char ch[2];

inline int get_int()
{
    int x=0,f=1;
    char c;
    for(c=getchar();(!isdigit(c))&&(c!='-');c=getchar());
    if(c=='-') f=-1,c=getchar();
    for(;isdigit(c);c=getchar()) x=(x<<3)+(x<<1)+c-'0';
    return x*f;
}

inline int get(int v){return father[v]==v ? v : father[v]=get(father[v]);}

int main()
{
    while(~scanf("%d%d\n",&n,&m))
    {
      if(!n && !m) break;
      ans=0,id=2*n,t++;
      for(int i=1;i<=n;i++) father[i]=i+n;
      for(int i=n+1;i<=n*2+m;i++) father[i]=i;
      for(int i=1;i<=m;i++)
      {
          scanf("%s",ch);
          if(ch[0]=='M')
          {
            x=get_int()+1,y=get_int()+1;
          if(get(x)!=get(y)) father[get(x)]=get(y);
          }
          else x=get_int()+1,father[x]=++id;
      }
      for(int i=n+1;i<=id;i++) vis[i]=0;
      for(int i=1;i<=n;i++)
      {
          int fax=get(i);
          if(vis[fax]) continue;
          vis[fax]=1,ans++;
      }
      cout<<"Case #"<<t<<": "<<ans<<"\n";
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值