What Are You Talking About
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)Total Submission(s): 24202 Accepted Submission(s): 8108
Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
Output
In this problem, you have to output the translation of the history book.
Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
Sample Output
hello, i'm from mars. i like earth!HintHuge input, scanf is recommended.
Author
Ignatius.L
Recommend
C++ STL中的map实在好用,对于查找单词,统计单词词频的题目再合适不过了
题目简单,用map的常用命令即可求解,可当做模板学习
#include <iostream>
#include <map>
#include <cstring>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int maxn = 3e5+10;
map<string,string> m; //一般都用字母m
char cc[maxn];
int main(){
string str1,str2;
cin>>str1;
while (cin>>str1 && str1!="END"){
cin>>str2;
m[str2]=str1; //构造新节点,存入数据
}
map<string,string>::iterator it = m.begin(); //生成一个迭代器
cin>>str1;
getchar(); //很重要
while (gets(cc) && strcmp(cc,"END")){
string s="";
for (int i=0;i<strlen(cc);i++){
if (cc[i]>='a' && cc[i]<='z') s+=cc[i];
else {
map<string,string>::iterator it = m.find(s); //查找单词
if (it!=m.end()){
cout<<it->second; //对应的英文翻译存放在第二个值里
}
else cout<<s;
cout<<cc[i];
s.clear(); //记得把记录的单词清空
}
}
cout<<endl;
}
return 0;
}