HDOJ1556 树状数组简单应用

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23142    Accepted Submission(s): 11237


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1542  1394  1255  2795  3397 

直接贴代码。。。

#include <iostream>
#include <ctime>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1e5+5;
int n,i,a,b,c[maxn];

int lowbit(int x){
    return x & (-x);
}

int sum(int pos) {
    int x=0;
    while (pos) {
        x += c[pos];
        pos -= lowbit(pos);
    }
    return x;
}

void add(int pos, int num){
     while (pos<=n) {
        c[pos] += num;
        pos += lowbit(pos);
     }
}

int main(){
    while (cin >> n && n) {
        memset(c,0,sizeof(c));
        for (i=1; i<=n; i++) {
            cin >> a >> b;
            add(a,1);
            add(b+1,-1);
        }
        for (i=1; i<n; i++) cout << sum(i)  << " " ;
        cout << sum(n) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值