HDOJ1532 最大流 BFS + EK 算法 模板

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18788    Accepted Submission(s): 8935


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

Source
 

Recommend
lwg   |   We have carefully selected several similar problems for you:   1533  3338  1569  3572  3416 

数据不大,用邻接矩阵存储比较方便。。
BFS代码实现很套路,对于最大流初学者很友好。
EK算法效率貌似比较低,但这题很水也就跑的很快过了。。。

#include <iostream>
#include <queue>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <cstring>
using namespace std;

const int maxn = 205;
const int inf = 1<<30;
queue<int> myqueue;
int i,j,k,n,m,s,e;
int c[maxn][maxn];
int flow[maxn],pre[maxn];

int bfs(){
    while (!myqueue.empty()) myqueue.pop();
    memset(pre,-1,sizeof(pre));
    memset(flow,0,sizeof(flow));
    flow[1] = inf;
    pre[1] = 0;
    myqueue.push(1);

    while (!myqueue.empty()){
        k = myqueue.front();
        myqueue.pop();
        if (k == m) break;
        for (i=1; i<=m; i++) {
            if (pre[i]==-1 && i!=1 && c[k][i]) {
                  pre[i]=k;
                  flow[i] = min(flow[k],c[k][i]);
                  myqueue.push(i);
            }
        }
    }

    if (pre[m]==-1) return -1;
    return flow[m];
}

int EK(){
     int max_flow,increase;
     max_flow = 0;
     while ((increase=bfs())!=-1) {
            max_flow += increase;
            k = m;
            while (k!=1) {
                i = pre[k];
                c[i][k] -= increase;
                c[k][i] += increase;
                k = i;
            }
     }
     return max_flow;
}

int main(){
    std::ios::sync_with_stdio(false);
    while (cin >> n >> m){
        memset(c,0,sizeof(c));
        for (i=1; i<=n; i++) {
            cin >> s >> e >> j;
            if (s==e) continue;
            c[s][e] +=j;
        }
        cout << EK() << endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值