HDOJ1394 求逆序对

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21799    Accepted Submission(s): 13029


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1540  1542  1255  1828  2871 

本题不难,先求一遍逆序对,然后逐个枚举情况就好了。
逆序对求法很多,归并排序,树状数组,线段树都可以。

代码如下:
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 5000;
struct node{
   int l,r,val;
}tree[maxn*4+10];
int num[maxn+10];
int a[maxn+10];
int n;

void build(int rt, int l, int r){
    tree[rt].l = l;
    tree[rt].r = r;
    tree[rt].val = 0;

    if (l==r) return;
    int mid = (l+r)/2;
    build(rt<<1,l,mid);
    build(rt<<1|1,mid+1,r);
}

void update(int rt, int pos){
    int l = tree[rt].l;
    int r = tree[rt].r;
    if (l==r) {num[rt]++; return;}

    int mid = (l+r)>>1;
    if (pos<=mid) update(rt<<1,pos);
    else update(rt<<1|1,pos);

    num[rt] = num[rt<<1] + num[rt<<1|1];
}

int query(int rt, int L, int R){
    int l = tree[rt].l;
    int r = tree[rt].r;
    if (L<=l && r<=R) return num[rt];

    int mid = (l+r)>>1,ans=0;
    if (R>mid) ans += query(rt<<1|1,L,R);
    if (L<=mid) ans += query(rt<<1,L,R);
    return ans;
}

inline int MIN(int x, int y){return x<y?x:y;}
int main(){
    int sum;
    while (scanf("%d",&n)!=EOF){
        sum = 0;
        memset(num,0,sizeof(num));
        build(1,0,n-1);
        for (int i=0; i<n; i++) {
            scanf("%d",&a[i]);
            update(1,a[i]);
            sum += query(1,a[i]+1,n-1);
        }
        int mn = sum;
        for (int i=0; i<n; i++) {
            sum = sum + n-1-a[i]-a[i];
            mn = MIN(mn,sum);
        }
        printf("%d\n",mn);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值