Drainage Ditches POJ - 1273 ----网络流之最大流

最大流详解,好博客:https://www.cnblogs.com/zsboy/archive/2013/01/27/2878810.html

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50
AC代码:

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=1e3+10,inf=0x7fffffff;
int c[maxn][maxn],flow[maxn],pre[maxn];
int n,m;
int bfs(int s,int t)
{
	queue<int> q;
	for(int i=1;i<=m;i++)
		pre[i]=-1;
	pre[s]=0;
	flow[s]=inf;
	q.push(s);
	while(!q.empty() )
	{
		int u=q.front() ;
		q.pop() ;
		if(u==t)
			break;
		for(int i=1;i<=m;i++)
		{
			if(i!=s&&c[u][i]>0&&pre[i]==-1)
			{
				pre[i]=u;
				flow[i]=min(c[u][i],flow[u]);
				q.push(i); 
			}
		}
	}
	if(pre[t]==-1)
		return -1;
	else
		return flow[t];
}
int maxflow(int s,int t)
{
	int sum=0,in=0;
	while((in=bfs(s,t))!=-1)
	{
		int k=t;
		while(k!=s)
		{
			int last=pre[k];
			c[last][k]-=in;
			c[k][last]+=in;
			k=last;
		}
		sum+=in;
	}
	return sum;
}
void solve()
{

	while(~scanf("%d %d",&n,&m))
	{
		memset(flow,0,sizeof(flow));
		memset(c,0,sizeof(c));
	
		for(int i=1;i<=n;i++)
		{
			int a,b,s;
			scanf("%d %d %d",&a,&b,&s);
			c[a][b]+=s;
		}
		printf("%d\n",maxflow(1,m));
	}
	
}
int main()
{
	solve();
	return 0;
}

下面是我找到解释比较清楚楚的代码:
改一点,队列定义在函数内就不用清零了

#include <iostream>
#include <queue>
#include<string.h>
using namespace std;
#define arraysize 201
int maxData = 0x7fffffff;
int capacity[arraysize][arraysize]; //记录残留网络的容量
int flow[arraysize];                //标记从源点到当前节点实际还剩多少流量可用
int pre[arraysize];                 //标记在这条路径上当前节点的前驱,同时标记该节点是否在队列中
int n,m;
queue<int> myqueue;
int BFS(int src,int des) {
	int i,j;
	while(!myqueue.empty())       //队列清空
		myqueue.pop();
	for(i=1; i<m+1; ++i) {
		pre[i]=-1;
	}
	pre[src]=0;
	flow[src]= maxData;
	myqueue.push(src);
	while(!myqueue.empty()) {
		int index = myqueue.front();
		myqueue.pop();
		if(index == des)            //找到了增广路径
			break;
		for(i=1; i<m+1; ++i) {
			if(i!=src && capacity[index][i]>0 && pre[i]==-1) {
				pre[i] = index; //记录前驱
				flow[i] = min(capacity[index][i],flow[index]);   //关键:迭代的找到增量
				myqueue.push(i);
			}
		}
	}
	if(pre[des]==-1)      //残留图中不再存在增广路径
		return -1;
	else
		return flow[des];
}
int maxFlow(int src,int des) {
	int increasement= 0;
	int sumflow = 0;
	while((increasement=BFS(src,des))!=-1) {
		int k = des;          //利用前驱寻找路径
		while(k!=src) {
			int last = pre[k];
			capacity[last][k] -= increasement; //改变正向边的容量
			capacity[k][last] += increasement; //改变反向边的容量
			k = last;
		}
		sumflow += increasement;
	}
	return sumflow;
}
int main() {
	int i,j;
	int start,end,ci;
	while(cin>>n>>m) {
		memset(capacity,0,sizeof(capacity));
		memset(flow,0,sizeof(flow));
		for(i=0; i<n; ++i) {
			cin>>start>>end>>ci;
			if(start == end)               //考虑起点终点相同的情况
				continue;
			capacity[start][end] +=ci;     //此处注意可能出现多条同一起点终点的情况
		}
		cout<<maxFlow(1,m)<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值